Vhargon's Bug Bundle

Vhargon

Well-Known Member
Joined
Nov 11, 2014
Messages
181
Likes
94
Points
445
Age
28
Location
Ottawa, Canada
#1
Hello, guys!

This post is going to be updated with new bugs/typos/etc whenever I find them. Whenever this post gets a significant edit, I will also reply to the thread to announce it.



This may contain bugs that you already know of, but I will still
include every bug that I've come across, for completeness' sake.


I've seen people make a few other "bug list" threads, but I haven't seen them kept updated. In that respect, I'm going to try to keep this as up-to-date as possible.



I'll be relying on other forum members to post replies to this thread with bugs they've also found, which I'll then add to this list.

Please try to make your bug reports as detailed as possible.
If you know how to replicate it, please provide instructions.

Bugs will be highlighted in green if they are fixed in the next update.

Without further ado, the list:


------------------------------
Confirmed bugs in v0.3.6 said:

STILL UPDATING LIST

Click here for the video playlist!

 
Last edited:

ShaunSchaf

Well-Known Member
Joined
Nov 8, 2014
Messages
27
Likes
3
Points
405
Age
40
#2
- Sometimes your base "remembers" things you put in refining / crafting queue in an other game when you start new.
- saving a game, then load it again somewhen later caused base to be nearly completely destroyed even with shield up and tons of fuel in stock. I could no reproduce this. It was just strange.
- gpu usage drops to zero causing game to be unplayable (
Mainboard : ASUSTeK COMPUTER INC. F1A55-M LK R2.0
Chipsatz : Family 12h/14h Link Control
Prozessor : AMD A8 3870 @ 3000 MHz
Physikalischer Speicher : 8192 MB DDR3-SDRAM
Grafikkarte : AMD Radeon HD 6570 2GB
Festplatte : TOSHIBA DT01ACA100 ATA Device (1000GB)
DVD-Rom Laufwerk : Toshiba-Samsung CDDVDW SH-224DB
Monitortyp : ViewSonic VA2248 SERIES - 22 inchs
Netzwerkkarte : Attansic (Now owned by Atheros) AR8161 Gigabit Ethernet
Betriebssystem : Windows 7 Home Premium Home Edition Media Center 6.01.7601 Service Pack 1 (64-bit)
DirectX : Version 11.00
Windows Performance Index : 5.9 auf 7.9
)
This happens very frequently.Sometimes gpu starts working again, sometimes it doesn't
 

Vhargon

Well-Known Member
Joined
Nov 11, 2014
Messages
181
Likes
94
Points
445
Age
28
Location
Ottawa, Canada
#3
New bugs added to list.

Also...
- saving a game, then load it again somewhen later caused base to be nearly completely destroyed even with shield up and tons of fuel in stock. I could no reproduce this. It was just strange.
This still happens in the current build?
 

ShaunSchaf

Well-Known Member
Joined
Nov 8, 2014
Messages
27
Likes
3
Points
405
Age
40
#6
and another one. At some point base stops working. No refining, no production, no selling. Cancelling all queues doesn't help. Savegame+last log added.
Plus a lot of game stuttering seems to be caused by ressource bubble in my case.
 

Attachments

Vhargon

Well-Known Member
Joined
Nov 11, 2014
Messages
181
Likes
94
Points
445
Age
28
Location
Ottawa, Canada
#7
and another one. At some point base stops working. No refining, no production, no selling. Cancelling all queues doesn't help. Savegame+last log added.
Plus a lot of game stuttering seems to be caused by ressource bubble in my case.
I think I've run in to this bug before. If I have, then it's caused by the resource blob being so big that the tractor beams aren't strong enough to pull specific pieces out.
 
Last edited:

Tinywar

Well-Known Member
Joined
Aug 13, 2014
Messages
273
Likes
98
Points
435
Age
47
#10
Laser goes through coal when trying to harvest it with the laser
Second time that you harvest trees
no resources fall out
 

Vhargon

Well-Known Member
Joined
Nov 11, 2014
Messages
181
Likes
94
Points
445
Age
28
Location
Ottawa, Canada
#11
Laser goes through coal when trying to harvest it with the laser
Second time that you harvest trees
no resources fall out
Can not reproduce either of those. Tried with both narrow and wide lasers. In addition, some trees just seem to not give resources, but whether that's intentional or not remains a mystery.

Are you using the 32-bit or 64-bit client?
 

Daniel Bø Golan

Well-Known Member
Joined
Aug 14, 2014
Messages
20
Likes
17
Points
415
Age
29
#12
Bug or feature ?
Travelled for a long trip into the dessert to get some new parts.
When i got back to the base i could connect parts to it and it had moved to a new spot.
The tractor pad was lying on the ground so i conneced it back and the refinery is missing !
http://imgur.com/2hvMUns
 

Vhargon

Well-Known Member
Joined
Nov 11, 2014
Messages
181
Likes
94
Points
445
Age
28
Location
Ottawa, Canada
#13
Bug or feature ?
Travelled for a long trip into the dessert to get some new parts.
When i got back to the base i could connect parts to it and it had moved to a new spot.
The tractor pad was lying on the ground so i conneced it back and the refinery is missing !
http://imgur.com/2hvMUns
Is this with the latest version, v0.3.2?
 

Tinywar

Well-Known Member
Joined
Aug 13, 2014
Messages
273
Likes
98
Points
435
Age
47
#16
Can not reproduce either of those. Tried with both narrow and wide lasers. In addition, some trees just seem to not give resources, but whether that's intentional or not remains a mystery.

Are you using the 32-bit or 64-bit client?
i'm using the 64-bit client
 

Vhargon

Well-Known Member
Joined
Nov 11, 2014
Messages
181
Likes
94
Points
445
Age
28
Location
Ottawa, Canada
#17
i'm using the 64-bit client
If it's still happening, can you think of anything you're doing differently that might explain why your lasers are passing through coal?

Is it just coal that it happens with?

Are you able to record a video of this? I'm so curious.