Unable to Upload to Steam Workshop

Falchoin

Well-Known Member
Joined
May 30, 2018
Messages
201
Likes
656
Points
305
Age
35
#1
No version on this one since I tried in both stable and unstable, but my issues started a couple days ago so the thread is being made here.

I cannont upload to the workshop on Steam. I've tried various suggestions on the Steam forums (like lowering the game resolution for a smaller screenshot) and removing some of my older posts to Steam since the log file appeared to indicate I'd reached some limit. Sadly 5 pages of deleted techs later I still cannot upload, in stable or unstable.

Attached is my log file from when I started the game, started a new Creative game, loaded in the tech I wanted to upload, and had it fail.
 

Attachments

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,792
Likes
5,222
Points
675
Age
36
Location
UK
Website
www.youtube.com
#2
Have you tried deleting the entire contents of TerraTech's "Cache" folder? That seems to have helped resolve this issue for others previously. Otherwise a temporary Steam server glitch, maybe..
 

HeX

TerraTech Modder Manager
Joined
Jul 4, 2018
Messages
166
Likes
167
Points
245
#4
It has been noticed that recently, the steam servers have been experiencing some issues and shutting down. It may be the source of your uploading issues.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,792
Likes
5,222
Points
675
Age
36
Location
UK
Website
www.youtube.com
#5
Tried that, didn't work.
Sad face.:(

Workshop upload problems also reported previously here:
(1) 0.8.1 - https://forum.terratechgame.com/index.php?threads/0-8-1-cant-upload-a-tech.16531/
(2) 1.0.1 - https://forum.terratechgame.com/index.php?threads/1-0-1-unable-to-upload-techs-to-steam.17586/
(3) 1.2.0.6 - https://forum.terratechgame.com/index.php?threads/1-2-0-6-cant-upload-techs-to-steam-workshop.19645/

In 2, @Sai Wun seemed to do something behind the scenes to help...

And I think it might have been @mozuo (?) who told me about clearing the cache as a possible fix (I might be making this up entirely).
 

Falchoin

Well-Known Member
Joined
May 30, 2018
Messages
201
Likes
656
Points
305
Age
35
#7
Just deleted the items in my cache again, still cannot upload to Steam.

If it helps, I get this lovely item in my workshop every failed attempt. I dunno if this is standard or not.
Unknown.png
 
Last edited:
Likes: ZeroGravitas

burger1113

Well-Known Member
Joined
Jan 3, 2015
Messages
271
Likes
478
Points
470
Age
31
#8
Just deleted the items in my cache again, still cannot upload to Steam.

If it helps, I get this lovely item in my workshop every failed attempt. I dunno if this is standard or not.
View attachment 29081
Yeah I get the same screen when I get the error as well. :(
How about you try to delete the cache folder altogether, try loading again, and make sure steam doesn't download the cloud file by choosing upload current files or somethin?
If you choice download cloud files, the cache files would return, so...
 
Likes: ZeroGravitas

Falchoin

Well-Known Member
Joined
May 30, 2018
Messages
201
Likes
656
Points
305
Age
35
#9
I turned off Steam cloud sharing shortly after this all started. Deleting the Cache folder entirely did not fix the issue. Uninstalling/reinstalling the game didn't work.
 
Likes: ZeroGravitas

Sdarks

PAYLOAD STUDIOS
Joined
Jun 13, 2018
Messages
274
Likes
452
Points
270
Age
25
#10
@Falchoin Usually these things are a result of the steam servers being a bit flakey and for whatever reason it seems to fix itself after a few days (sometimes as long as a week). However your issue seems to be a specific error coming back from steam that is suggesting the file size on your thumbnail is too large. Could you upload to here a snapshot of the tech you're trying to share please? I'm assuming this is only the case with a specific tech?
 

Sdarks

PAYLOAD STUDIOS
Joined
Jun 13, 2018
Messages
274
Likes
452
Points
270
Age
25
#12
How many snapshots in your snapshots folder, too (kinda just curious, but if there's a few hundred, that would repopulate the cache folder, I guess). But, what Sdarks said.
In this case it's specifically a thumbnail/preview image over 1MB in size. Although I did also think it could be too many snapshots at first it's nothing related to that.
 

Falchoin

Well-Known Member
Joined
May 30, 2018
Messages
201
Likes
656
Points
305
Age
35
#13
It appears my upload issue has been fixed by disallowing Steam sync, deleting my cache, deleting all the files in my user data Steam folder (Steam>userdata>[SteamID]>285920), enabling Steam sync and starting the game then choosing to upload local files to the cloud. This reduced over 200MB of cloud files to 98MB.

Or it magically fixed itself at roughly the same time. The world may never know!

Thank you all for your suggestions and time.

For the record, I've got 149 snapshots in my Snapshots folder.
 
Likes: Sdarks

Sdarks

PAYLOAD STUDIOS
Joined
Jun 13, 2018
Messages
274
Likes
452
Points
270
Age
25
#14
It appears my upload issue has been fixed by disallowing Steam sync, deleting my cache, deleting all the files in my user data Steam folder (Steam>userdata>[SteamID]>285920), enabling Steam sync and starting the game then choosing to upload local files to the cloud. This reduced over 200MB of cloud files to 98MB.

Or it magically fixed itself at roughly the same time. The world may never know!

Thank you all for your suggestions and time.

For the record, I've got 149 snapshots in my Snapshots folder.
Sounds like yet another case of Steam just being a bit weird :)
 
Likes: Falchoin

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,792
Likes
5,222
Points
675
Age
36
Location
UK
Website
www.youtube.com
#15
Last edited:

Falchoin

Well-Known Member
Joined
May 30, 2018
Messages
201
Likes
656
Points
305
Age
35
#17
Looks like @Falchoin's upload trouble is over: https://steamcommunity.com/sharedfiles/filedetails/?id=1876929872




So you deleted "UserData.sav" in the "Saves" route folder? (Resetting the game's list of users and game settings.)
Nope, I deleted the "remote" and "remotecache.vdf" from Steam>userdata>[SteamID]>285920 . My understanding is this causes Steam to think the Steam cloud should have zero files. So when you re-enable Cloud sync and you choose to upload your local files, it clears the old data and only keeps what you actually have at that point.

I think.

Maybe.
 
Likes: ZeroGravitas