Unable to play TerraTech.

Vertu

Well-Known Member
Jun 10, 2020
84
104
135
After obtaining the latest DLC skins, steam started acting up and unable to load TT, after restarting steam it started working for the first time ever, (I had to manually activate steam games and use indirect paths into steam but never could use steam itself directly until now), and TT is unable to complete loading the initial screen (I assume it's asset loading) in what was previously called an "infinite loading bug" though I believe that was about making steam mods for TT, I just downloaded DLC which I have done before with no issue.

Any advice would be heavily apricated, the main issue I have been able to confirm is that TT was seemingly moved from its original file location as evidenced by TerraTech Mod Manger being unable to find TT in it's original location, "Location Of TerraTech (Invalid)" though after looking in the files, nothing seems to have moved.
 

burger1113

Well-Known Member
Jan 3, 2015
455
789
505
33
Might want to try saving all the techs on the workshop, and reinstalling the game, making sure that all the files are indeed deleted. I had an infinite loading bug fixed that way. Good luck!
 
  • Like
Reactions: Vertu and Skihiley

Vertu

Well-Known Member
Jun 10, 2020
84
104
135
Thank you very much, it has indeed solved the problem of TT's loading.
Also apparently everything was preserved.
It seems that "TerraTech Beta" became invalid upon downloading modern DLC content, after reinstalling, all of "TerraTech Beta" 's major contents where moved into "TerraTech", all I had to do was move TTMM's destination to there. Thank you again for your help.
 
Last edited:
  • Like
Reactions: Skihiley