Twitter Integration is Not Working For Me (Post Twitter Connection Problems Here)

Roadkill

Well-Known Member
Joined
Jul 11, 2015
Messages
22
Likes
15
Points
110
Age
44
#1
Every time I try to Tweet anything or link to Twitter I get "UWKProcess.exe has stopped working" and the game crashes to desktop.
 

KattStrike

Well-Known Member
Joined
Aug 19, 2015
Messages
247
Likes
167
Points
440
Age
28
Website
twitch.tv
#3
Hey guys, so after lots of people complaining about Twitter Integration problems, I have created this thread in order to collate all of your info.


In the thread below I have moved other posts from the Twitter Integration thread, after those could you all please post your problem and the following (Please answer as many as possible);


What operating system are you using?
What CPU do you have?
How much RAM do you have?
What video card are you using, if you have one?
What sound card are you using, if you have one?
What programs do you have running while trying to link with Twitter?
Where did you buy the game? (Steam, Humble, Other [please specify])

(Thank you IceFireXD for the questions!)

Please try and be as descriptive as possible guys, this way we can address the problem a lot faster on our end.
 

timmm06

New Member
Joined
Oct 2, 2015
Messages
8
Likes
0
Points
2
Age
24
#4
I'm not getting the crashing problem like the first guy is, but I'm not getting anything either. Just this white screen is all, and on rare occasions I get the google homepage too. I have tried everything I can think of and I have searched everything twitter related on the forums, but I still cannot find an answer for this.

My specs are:
-Windows 8.1
-I do not know how to check my CPU (unless if you mean the CPU being used while the game is running)
-8.00 GB of RAM
-AMD Radeon R5 Graphics
-I do not know my current sound card
-Only the bare minimum that my laptop requires to actually run. I have tried a reboot of my laptop to try and get any excess programs to stop (did not work)
-I bought it from Steam

I hope this helps. I'm sure I'm not the only one with this white screen being displayed.
 

Attachments

harpo99999

Ah kick till it starts
Joined
Aug 14, 2014
Messages
2,184
Likes
1,097
Points
570
Location
australia
#5
timmm06, the quickest way to get the CPU specs/model is in windows explorer right mouse click on the computer then left click on 'properties'
windows WILL tell you the cpu model in th system properties page
 
Joined
Oct 6, 2015
Messages
3
Likes
0
Points
7
Age
28
#7
I am trying to integrate twitter, and it is asking me for a pin (no idea where that comes from) and I can't find anything on how to get it. Then, when I click submit, it bounces back to the world creation screen and randomizes the seed again.

It may be relevant that I am running it on Linux. I am able to connect to Twitter on Windows, but the performance takes a hit, so I'd prefer to be able to connect it on Linux
 
Last edited:

KattStrike

Well-Known Member
Joined
Aug 19, 2015
Messages
247
Likes
167
Points
440
Age
28
Website
twitch.tv
#8
I am trying to integrate twitter, and it is asking me for a pin (no idea where that comes from) and I can't find anything on how to get it. Then, when I click submit, it bounces back to the world creation screen and randomizes the seed again.

It may be relevant that I am running it on Linux. I am able to connect to Twitter on Windows, but the performance takes a hit, so I'd prefer to be able to connect it on Linux
This is a known Linux problem I'm afraid. It's a library issue - due to limited web browser support on Linux :(
 

timmm06

New Member
Joined
Oct 2, 2015
Messages
8
Likes
0
Points
2
Age
24
#10
I am able to connect to Twitter on Windows, but the performance takes a hit, so I'd prefer to be able to connect it on Linux
How big of a hit? I ask because that hit might be why I am unable to connect. (I run windows)
 

dlmarti

Well-Known Member
Joined
Oct 8, 2015
Messages
12
Likes
1
Points
405
Age
55
#11
This is a known Linux problem I'm afraid. It's a library issue - due to limited web browser support on Linux :(
Not sure where you heard this, but TerraTech is the ONLY application I have ever seen that is unable to open a browser window in Linux. I have been using Linux since the 90's and I have never seen this problem before.

I believe it is solely a TerraTech issue.
 

Dellamorte

Well-Known Member
Joined
Feb 10, 2015
Messages
1,289
Likes
636
Points
520
Age
41
Location
Cairns, Australia
#12
Not sure where you heard this, but TerraTech is the ONLY application I have ever seen that is unable to open a browser window in Linux. I have been using Linux since the 90's and I have never seen this problem before.

I believe it is solely a TerraTech issue.
I this not an issue with TerraTech as such as far as I know it lies in the plugin that it uses (uWebkit).
 

Bigtoad

Well-Known Member
Joined
Oct 9, 2015
Messages
88
Likes
26
Points
115
Age
57
Location
Oregon
#13
I'm trying to enable Twitter for the first time. I'm using a Mac and I have tried it with both Chrome and Safari as my default browser. All I get at the verification/sign up step is a window with a blank white screen.

My computer is a 17" Late 2011 Macbook Pro (the last 17" model Apple made)
What operating system are you using? Mac OS X 10.10.5 (Yosemite)
What CPU do you have? 2.5GHz Intel Core i7
How much RAM do you have? 16GB
What video card are you using, if you have one? AMD Radeon HD 6770M
What sound card are you using, if you have one? USB Audio Codec (on Belkin Thunderbolt 2 Express Dock HD, I'd have to do some fiddling to get the specific sound chip information, don't think it's relevant to this issue.)
What programs do you have running while trying to link with Twitter? Chrome, Safari, Firefox (I use each for different purposes), Truecrypt, Terminal, Steam, Activity Monitor, Excel, Preview, Thunderbird
Where did you buy the game? (Steam, Humble, Other [please specify]) Humble, currently running the Steam version because Humble is behind.
 

ArmchairGravy

Well-Known Member
Joined
Aug 28, 2015
Messages
450
Likes
404
Points
470
#14
I make sure the Twitter box is checked before starting a new game, but I'm being asked to authorize Twitter after a reload of the save. Is there a way to get Twitter authorization to stick with a save? At this point I'm uploading a snapshot as soon as I load a game and am being asked to authorize Twitter on each and every load.
 

PVT.S2H

New Member
Joined
Oct 19, 2015
Messages
3
Likes
0
Points
2
Age
16
#16
When start up my game using twitter, it opens up this white screen... Just plain white... Help!
 
Joined
Oct 20, 2015
Messages
1
Likes
0
Points
2
Age
27
#20
Im having the same issue as PVT.S2H. I cant login to twitter in game because it just gives me a white screen with nothing to click. And when i can get it to open the browser it sends me to google. How would i go about fixing this?