Startup bug

Discussion in 'Bugs (Stable Only)' started by MutedMicrophone, May 8, 2018.

Tags:
  1. MutedMicrophone

    MutedMicrophone New Member

    Whenever i load up the game, it just crashes... this is what the the crash log says

    Unity Player [version: Unity 2017.1.0p4 (892c0f8d8f8a)]
    TerraTechWin64.exe caused an Access Violation (0xc0000005)
    in module TerraTechWin64.exe at 0033:4ee6ed4f.
    Error occurred at 2018-05-08_080924.
    C:\Program Files (x86)\Steam\steamapps\common\TerraTech Beta\TerraTechWin64.exe, run by Muted.
    53% memory in use.
    5607 MB physical memory [2581 MB free].
    11239 MB paging file [6640 MB free].
    134217728 MB user address space [134217244 MB free].
    Read from location 00000020 caused an access violation.

    im not sure what that means but yea. If its possible can you show me what to do?
     
    ZeroGravitas likes this.
  2. ZeroGravitas

    ZeroGravitas Breaker of Games

    Thanks for the report. Can you confirm that you are using game version 0.7.9 (the default)?

    Also, it may be worth running DxDiag.exe and uploading the output file here, please (so devs can see your system specs and setting).
    Otherwise... @kae, halp!
     
  3. harpo99999

    harpo99999 ah kick till it starts

    given the 6gb, (which suggests it might be a laptop), it might be an updated driver putting the terratech game to the intel gpu, also it might be a windows update having caused the issue, but without further info we can not help further
     
  4. MutedMicrophone

    MutedMicrophone New Member

    I am pretty curtain the "access violation" it is talking about is that its trying to access my C: drive and it does not have access, therefore windows is forcefully making it crash

    how do i change this
     
  5. QuackDuck

    QuackDuck Duck

    Try setting TerraTech to Run as administrator.
     
    ZeroGravitas likes this.
  6. ZeroGravitas

    ZeroGravitas Breaker of Games

    Good point. May be related to the recent change in save files, etc, location. Perhaps best if you are logged in on an admin account when installing and running the game, to be safe. (Not sure.)
     
  7. Zorgomol

    Zorgomol Well-Known Member

    Um, no. Access violation is about memory access. In W9x it was called general protection fault and in unix systems segment violation.
    What probably happened here that the game tried to allocate memory, failed, and got a null pointer instead (00000020), didn't notice and tried to access it anyway. Windows kernel said nope.

    If this happens when loading a save then the save might be corrupted. If it happens when starting the game then game files might be corrupted and then steam's 'verify integrity of game files' is your friend. If that does not help either then your computer might have too little memory or be otherwise somehow incompatible with the game.
     
  8. Zed

    Zed Well-Known Member

    The short answer to this question is "Rigorous Troubleshooting"

    In longer form the first step would be reading through this Steam Discussion wherein one of the posters provided a decent step by step list of potential sources for this type of memory access error. ( https://steamcommunity.com/app/242760/discussions/1/1697167355213626732/ )

    Of the steps listed there I would suspect "Corrupted Installation of Windows" / "Faulty Ram (so)dimm".

    Alas, neither of these are especially "tech-neophyte" friendly....

    My list of suggestions would be (in order of severity)

    1) Corrupted game installation:
    Uninstall Terratech
    Reboot
    Check for Windows Updates (including any optional .net frameworks (4.7)
    Update Graphics Driver(s)
    Reboot
    Reinstall TerraTech.

    If this Fails:

    Begin by backing up *all* personal information of yours on the computer in question (DVD-R / USB / etc)
    Find a friend who is tech savvy

    2) Attempting to repair Windows
    Find your Windows repair Disk (some laptops have this on a second HDD partition instead of a physical Disk)
    Download an "ISO" of your current version of windows (worth having)

    2a) Check for Viruses (I happen to prefer Avast since it is free and will report nearly all issues in detail)
    Remove unneeded / unrecognized programs from Windows Control Panel "Add / Remove Programs"
    Activate Windows Defender and after it updates to newest definitions let it run a full scan (above and beyond Avast)

    (If Windows Defender refuses to start / run please refer to http://www.thewindowsclub.com/error-0x800106a-windows-defender-will-not-turn-on )

    3)Use Windows Restore Point
    Typically Windows will save restore points of itself periodically which permits you to restore your computer to an earlier configuration without too much difficulty and can be used to bypass many serious computer issues, Best advice is to pick one more recent first and work your way backwards but not too far. This procedure usually takes 10 minutes and can be very helpful if you "misclick" on a questionable website.

    Hopefully this advice will be of help improving your Terratech experience; as the aforementioned steam discussion mentions more advanced options (such as reinstalling windows) will take the better part of a day (for a windows 7 reinstall + updates) I would suggest sleeping on such a choice before considering them especially if you do not have an additional computer at your disposal.

    Professional repair (such as microcenter stores here in the United States) or searching for a new(er) computer (check craigslist listings) for gaming since Terratech Itself "requires" 4GB of RAM above and beyond the 2-6GB most modern operating systems require the 6GB on your computer is less than what is recommended for Terratech.

    Hopefully this long post will be of help in improving your Terratech Experience; I encourage you to ask any and all followup questions before taking any measures of which you are unsure.
     
  9. kae

    kae PAYLOAD STUDIOS

    Thanks for the helping out everyone!
    Is this issue still a problem for you MutedMicrophone after following the advice of whats been posted?

    The first thing I would suggest doing is verifying the integrity of the steam files/or uninstalling and reinstalling and make sure all your drivers are up to date.

    If it still does not boot correctly could you send me a DxDiag with the crash dumps and logs as ZeroGravitas has suggested and I'll take a look at it.

    Cheers!
     

Share This Page