Snapshots disappeared

Dragonking

Well-Known Member
Joined
Apr 6, 2019
Messages
28
Likes
60
Points
115
#1
Some of my recent snapshots have disappeared in the snapshots Folder in-game,but when I look in the Folder in documents ,where they are stored These snapshots`pictures are still there(These Pictures seem to somehow be able to store all the tech data although they are simple pngs(how does this work?))but i cant get them in game.Also the Alternate Color schemes have disappeared from all my techs.
 

mozuo

Well-Known Member
Joined
Jun 4, 2018
Messages
9
Likes
25
Points
215
#2
>Also the Alternate Color schemes have disappeared from all my techs.
Me too. (ver.1.2.0.1)
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,711
Likes
5,057
Points
675
Age
36
Location
UK
Website
www.youtube.com
#3
Some of my recent snapshots have disappeared in the snapshots Folder in-game,but when I look in the Folder in documents ,where they are stored These snapshots`pictures are still there
I always strongly suggest that everyone backup their snapshots manually to another (safe) location.

After doing that, try deleting the problematic ones from the folder (the game will need to be running for any deletions to stick, if you have steam cloud sync enabled for the game).

Then copy the snapshots back in from the external location. (Actually this might work without deleting them.)

You can also try deleting the entire contents of the "Cache" folder (safe to do at any time I believe). In the same location as your "Snapshots" folder.



These Pictures seem to somehow be able to store all the tech data although they are simple pngs(how does this work?)
The tech data (which is very small) is encoded into the least significant bit of the pixel data (or the alpha channel, or whatever it is). It essentially 'stenography. It means that if you edit the pngs in an image editor you will loose the tech data and they won't be loadable.



Also the Alternate Color schemes have disappeared from all my techs.
The devs reworked the texture sheets or whatever and there were a bunch of blocks that look different now, maybe this is related:
Oh, you guys tweaked the default GSO skins so the Stud Laser lost it's red. Deliberate?

View attachment 27506
Yes, a load of GSO models were updated recently to address some inconsistencies across skins. The red colour was used in a few places, which looked odd in some skin variations so we decided to make the dishes on the lasers a more neutral colour.
 
Likes: mozuo