Serious error, what to do?


Well-Known Member
Jul 6, 2018

I have a serious problem: Since the 1.4.5 update of the 29th, Terratech encounters systematically a "Serious error" right after I try to load my previous save, load a new game (whatever mods it is, campaign, R&D, creative mod, etc...).

Terratech screen 1.png

serious error screen.png
To resolve this I tried different solutions:
-Turned off the Terratech Mod Manager,
-The one from the Troubleshooting page, didn't worked,
-Renaming "Saves" folders didn't worked,
-Tried to switch betas, solution used by Adriano to solve a problem from the 1.4.1 update, didn't worked neither,

I can't apparently link a copy of my "Saves" folder, it's apparently too big, even zipped...

I'm quiet desperate at the moment since this game has become one of my rare source of enjoyment specially considering the situation, here in France as become what it is.

I would like to thank everyone for their help.

Best regards,



Well-Known Member
Jan 3, 2015
Hmm I'm not a dev but what I could say is :
1. You haven't tried reinstalling the game yet I think? Maybe it's an option.
2. You should probably upload the latest save file here so a dev can look at it.
3. Tell us exactly what mods you were using.
4. This should go to the "bugs" forum board so a dev will see it.


Well-Known Member
Jun 10, 2020
I have had this problem before in the past. It has to do with an object that TT is over reacting to, like an enemy tech due to some strange reason. In the future, make a manual save and backup save, you can use one of the saves to create a quick save when a bug report shows up (because they don't force you out of TT except for serious ones) incase the auto-save is unusable for whatever reason (practical or objective). If you don't have any backup save and you are indeed stuck, please include more details if I fail to provide an applicable solution. I am a good troubleshooter as I tend to break games easily by pushing them far along with knowing how glitches can arise based on game mechanic interactions.

1) If you are not forced out of TT, create a manual save and b-line away from any tech within the immediate facinity, if it happens after a certain amount of time, then more information is required for an accurate analysis on my part.

2) Considering past TTMM experiences, there are some old mods within it that have became outdated and run the risk of causing a crash upon trying to load fully. Disable some of the mods within TTMM, major suspects are the more invasive mods like motion blocks which add blocks with foreign code and methodology into TT, mods like Weapon Aim are "passive" and noninvasive, those mods are the least likely to be causing this. This "option" heavily applies to how you get a crash report when you load any TT world.

3) I heavily doubt this has to do with the files. Though in a worst case scenario you might need to uproot some connections to TT and possibly just, re-install it.

I don't have the most troubleshooting experience, sorry if this is insufficient but more details on this would be appreciated if need be.