Refinery Output Bug

Saelem Black

Tinker, Tailor, Soldier, Spy
Joined
Aug 25, 2018
Messages
520
Likes
1,748
Points
505
#1
This may be very old, but I noticed something with refineries -

A refined chunk, when created by a refinery, will skip the holding beam of the refinery if there's an open conveyor attached to the output. The refinery's own holding beam will only activate if all the output conveyors are already holding resource chunks. The animation "appears" to place the output chunk in the spot where the holding beam would catch it, but the holding beam never activates unless the output is blocked. It's as if the the priority of the output conveyor beams is higher than the priority of the refinery's own beam.

I don't know if this is working as intended, or a bug, but I've noticed that this is a big factor in crafting glitchiness on moving, enclosed, or turboed techs because this often forces chunks to pass through colliders of neighboring blocks; which, in turn, sometimes causes the chunk to break free from the holding beam.

1593541815322.png

1593541909669.png
 
Likes: Rafs

Bazzietuk

Well-Known Member
Joined
Sep 7, 2019
Messages
90
Likes
90
Points
120
#2
Haven't tested this but I know first hand the crafting system is broken and won't ever be fixed in this game, there's plenty of threads about complications in the manufacturing and crafting system and I've had discussions about it and been told it's not a priority to fix as it'd mean a complete rewrite of the game to sort all the problems out with it. It's especially annoying when trying to build a complete scrapper, refinery, storage, fabricator and manufacture base all in one. I have some designs of vertical refinery's on this site to play with but they all have issues in the production lines which can't be fixed. It's quite annoying. Personally nowadays I don't bother I'd rather just sell resources after refining them to get money to use the payload terminals to purchase needed blocks instead of trying to build them myself.