Newest Beta Feedback

Whensgen

Well-Known Member
Aug 14, 2014
194
142
450
Alright. This was the first time that I found myself truely lost in the game. I normally try and keep my construction neat and symmetrical. I looked at my vehicle to try and find a nice point to attach my new hammer, and realized that I had mounted a fully driveable GSO chassis, complete with tractor pads, onto a GeoCorp base, which had 3 big tires, and one GSO trekker wheel on a stilt, with over 15 mortars. And I said to myself "What the **** was I thinking!?"

That's when I became really, really excited for the future of this game.

That being said, there's something stuck under my base, and my resource stack is so tall I can't see the top of it.
And please, please let me save.

Other than that? This game is now awesome. Attached is the last saved version of my frankensteinedAmalgam3.png creation
 
  • Like
Reactions: Jamie and Sai Wun

Whensgen

Well-Known Member
Aug 14, 2014
194
142
450
Save is coming! Also, devs? Any way for you to add a key to skip that opening sequence, and just throw you right into the game with the finished vehicle, without making you build it yourself each time? That really makes starting new games repetitive
 

Whensgen

Well-Known Member
Aug 14, 2014
194
142
450
Lots of notes, but I really like the longer despawn time now. It feels well balanced. There's parts when I want to build, and just about when they get in the way, they vanish
 

Arrow

Well-Known Member
Sep 21, 2014
46
41
415
30
I tried building a tower or something using the rotating block. It didn't work because the cab kept shuffling around at the bottom. =P
 

zytukin

Well-Known Member
Aug 13, 2014
65
58
415
39
Any way for you to add a key to skip that opening sequence, and just throw you right into the game with the finished vehicle, without making you build it yourself each time?
One of the main things I liked about loading vehicles before the beta release.
Start the game, load a post-tutorial vehicle, have fun playing.
 

Whensgen

Well-Known Member
Aug 14, 2014
194
142
450
Interesting bug:
I disassembled my vehicle inside the shield. The parts I removed were flung so far I couldn't get them back :(

Also, the huge resource tower knocked the tractor pad I had built way up high, ontop of the resource stack. I can't move the camera to see it, which would let me grab it, or build another, as it is taking up the output slot
 
  • Like
Reactions: Jamie

Jamie

PAYLOAD STUDIOS
Sep 16, 2014
3,707
4,034
675
29
London, UK
These are all great notes! I shall pass them on to the dev team right away.

Interesting bug:
I disassembled my vehicle inside the shield. The parts I removed were flung so far I couldn't get them back :(
I believe this is fixed now (we discovered something similar when showcasing the game at EGX) - so that will be included in the next patch!


Thanks for the feedback :)