Linking Your Twitter Account With TerraTech

Discussion in 'Newbies' started by KattStrike, Sep 3, 2015.

  1. KattStrike

    KattStrike Well-Known Member Ex-Lemon King

    According to John, It's a library issue - due to limited web browser support on Linux.

    Also, I've been reporting this issue to the devs. We've had a big problem as no one can seem to send a log, so we're going to do some in-house testing.
     
  2. Estecka

    Estecka Well-Known Member Beta Deluxe

    In the futur, will it be possible to disable auto-tweeting when sending an invader off ?
     
  3. Robert Stolorz

    Robert Stolorz Well-Known Member Beta Deluxe TT Translator

    I would be happy to submit any logs necessary.

    Also, would it be easier to somehow integrate the steam overlay browser into the authentication? I'm pretty sure the steam overlay has an API to pass information to the browser. For linux this might be easier than integrating direct browser support into the linux version of the game.
     
  4. Jamie

    Jamie PAYLOAD STUDIOS Developer Community Manager

    When we enable Steam workshop integration - sure thing!
     
    Estecka likes this.
  5. timmm06

    timmm06 New Member Beta Deluxe

    I tried this and it worked out all the way up until the authorization screen appears. It just displays Google or a white screen. Did I do something wrong?
     
    Last edited: Oct 3, 2015
  6. EnTro

    EnTro Member Beta Deluxe

    I don't have twitter, and wasn't really planning on setting one up just for the game. Is there another way?
     
  7. Smoovious Laxness

    Smoovious Laxness Well-Known Member Beta Deluxe

    If you can do it without requiring my browser to be open, that would be ideal... it takes away resources from the game.
    This is the only thing preventing me from participating.

    (doing it via Steam would be best, since it would already be open)

    -- Smoov

    edit: 05-Nov-2015: I enabled it, and am happy to confirm, it doesn't need to have your browser open... (assuming I'm doing it right)
     
    Last edited: Nov 6, 2015
  8. Kevinhoofddorp

    Kevinhoofddorp New Member Beta Deluxe

    I have a problem when i click tweet me game shuts down
     
  9. Jamie

    Jamie PAYLOAD STUDIOS Developer Community Manager

  10. Nullpersona

    Nullpersona Well-Known Member Beta Deluxe

    Is there a way to access these features without Twitter, and by extension another e-mail?

    I quit Twitter a while ago, and would prefer not to have to subject myself to that again.
     
  11. LordZoltan666

    LordZoltan666 New Member

    Same issue here with Twitter, Start new game and select twitter, and then game just crashes with no error logs produced. Anyone else get this?
     
  12. JohnB

    JohnB PAYLOAD STUDIOS Developer Coder

    Hey guys.

    The latest unstable version (0.5.2.20) has a complete rework of Twitter, which should hopefully resolve these issues.
     
    IdontRuin likes this.
  13. WillyGamesYT

    WillyGamesYT Well-Known Member Beta Deluxe TT Translator Hero of the hour

    My TT keeps crashing too.

    Specs: Windows 8.1 Pro K 64 bit, x64 processer
    Intel(R) Core(TM) i5-5200 CPU 2.20GHz
    RAM: 8GB
    Intel(R) HD graphics 5500

    Plz help me with the problem...I can't send Invaders anymore.
     
  14. JohnB

    JohnB PAYLOAD STUDIOS Developer Coder

    @WillyGamesYT, which version of the game are you running? Could you please explain at what point the game crashes.
     
  15. WillyGamesYT

    WillyGamesYT Well-Known Member Beta Deluxe TT Translator Hero of the hour

    I am currently running 0.5.19.
     
  16. JohnB

    JohnB PAYLOAD STUDIOS Developer Coder

    @WillyGamesYT - the latest unstable version on Steam contains a rework of the Twitter functionality, which should hopefully resolve your issues. I would suggest either switching to using the Unstable version or waiting for the next stable build (I can't give you an exact date for this, but it should be within the next few weeks).
     
  17. JohnB

    JohnB PAYLOAD STUDIOS Developer Coder

    Apologies, I just checked and discovered that the Twitter fixes are in the latest Stable version: 0.5.21.

    Please grab the latest stable version of the game from Steam and it should work.
     
    Jamie likes this.
  18. harpo99999

    harpo99999 Well-Known Member Beta Deluxe

    also the humble store has the 05.21 stable as well
     
  19. reaperx1

    reaperx1 Well-Known Member Beta Deluxe Canary Dancing Tech .

    When you send an invader is it supposed to happen instantly or is there a waiting period before the tech is sent out?

    I tried to send my maze as an invader, but it just sat there. I got bored after a few minutes and went for a tour. I have not been back to see if it was sent yet. That was yesterday using version 0.5.21.

    It didn't get picked up with the build beam or send me to another tech. I was able to keep playing normally so it made me wonder if this is how it works now.

    Have a good one
     

Share This Page