Launching the Game Full-screen Windowed

Lost Ninja

Well-Known Member
Joined
Jul 17, 2015
Messages
1,213
Likes
867
Points
520
Age
44
Location
Yorkshire Dales under a rock.
#1
f like me you like to be able to do other things a long side playing TerraTech (browsing the internet, watching YouTube... those sorts of things...) ;) Or indeed just like me have a 2nd (or more) monitors, you'll have noticed that you have the choice of playing in a less than full screen window or full-screen but when you can't easily do things elsewhere without the game minimising. Which is fine if your Tech is safe... not so good when it's not... and sometimes when you think it is it isn't. So:

With thanks to @Zed who mentioned a steam discussion regarding command line arguments that can be passed to the game. (https://forum.terratechgame.com/ind...display-to-21-9-resolution.16948/#post-120017)

After some further digging I found a list of the various options that applied to another Unity game and found that like I hoped it worked with this Unity game... :D

Now not 100% sure how this works specifically as I applied it to a game that normally plays in a 1680x1050 window (largest I can have on my 1920x1080 screen). So it might be wise to experiment somewhat, then again if you want a full-screen windowed (borderless) at 1920x1080, my settings should work.

So to do this there are two methods, run can be done directly to steam and will in future always function like this, if you'd prefer to have the option to run normally or as above then it's a little more complicated.

Method One: Steam Launch Options
  1. Open Steam
  2. Right Click TerraTech and select Properties
  3. In the General Tab (at the top of the Properties window) click "Set Launch Options..."
  4. Copy/Paste the following:
    Code:
    -popupwindow -screen-width 1920 -screen-height 1080
    If you want to use a different resolution adjust the width/height appropriately.
  5. Press okay.
  6. From now on whenever you launch TerraTech from within Steam it will launch into a fullscreen borderless window.
Method Two: Creating a Shortcut.
  1. Nothing especially complicated here just a bit more involved. To start with once again go into Steam.
  2. Right Click TerraTech and select Properties
  3. Select Local Files from the tabs at the top. Then click "Browse Local Files..."
  4. This will cause a Windows File Explorer to open showing the directory of TerraTech.
  5. Right Click the item named TerraTechWin64.exe, (it's the only one with a blue icon), select "Send To" and then "Desktop (create shortcut)". You can close this window now.
  6. On your Desktop you should now have an icon with the name "TerraTechWin64.exe - Shortcut" the icon will look like the TerraTech logo (small blue square with white cross inside).
  7. Right Click this Icon and select "Properties".
  8. If it's not already selected click on the tab labelled "Shortcut".
  9. The top most editable box is labelled "Target:" click into this box and go all the way to the end.
  10. After the closing quotation mark => " <= place this code, changing height and width to your desired resolution if needed.
    Code:
    -popupwindow -screen-width 1920 -screen-height 1080
    Click okay.
  11. When you run this shortcut you will get a popup from Steam making sure that you know you're using the command line arguments, click Okay on this and the game will Launch in a Full-screen Border-less Window.
And that's it. I understand that wide screen resolutions will distort the UI, and non-standard resolutions might break your monitor. It is recommended that you only use this "method" if you know what you're doing and I won't be responsible for something going wrong.

A list of 16:9 resolutions can be found here: https://pacoup.com/2011/06/12/list-of-true-169-resolutions/ it goes up to 8k I think.
 
Last edited by a moderator:

merkesch

Well-Known Member
Joined
Jun 29, 2018
Messages
17
Likes
21
Points
110
#2
thank you very much :)
I chose Method One
The terratech start popup still opens up, but the resolution settings shown in that popup are ignored