Help Us Optimise TerraTech

NiveliKing

Active Member
Sep 25, 2015
5
1
41
Genoh, Nesla
galaxyonfire.wikia.com
C: Poor frame rate is an issue that occurs when I try to restore it to a decent graphics standing.

Processor: 3 GHz Intel Core i7
Installed Memory (RAM): 16GB
System type: 64-bit Operating System
OS: Mac OS X 10.11.3

Graphics Options
Resolution: 1344x756 (I would love for it to be better.)
Quality: Fastest (I want at least "Good.")
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: Off
Full Screen: Off
Anti-aliasing: Off
Gamma: 10%
Draw Distance: 50%
 
  • Like
Reactions: Jamie

madmanDylan

New Member
Jan 26, 2016
2
1
4
18
C: Poor frame rate is an issue that occurs when More than voor lights appear in-game.

Computer: Acer Aspire
Processor: Not known
Installed Memory (RAM): 8 RAM
System type: 64-bit Operating System, x64-based processor
OS: Windows 10

Graphics Options
Resoultion: 600X400
Quality: Fastest
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: Off
Full Screen: On
Anti-aliasing: off
Gamma: 10%
Draw Distance: 50
 
  • Like
Reactions: Jamie

Jamie

PAYLOAD STUDIOS
Sep 16, 2014
3,723
4,066
675
30
London, UK
i don't think t just down to poor frame rate iv done a test were left it for about 30 to 40 mins still crashed i don't know if it coz of my pc low spec i have the roport and will post.

Processor: AMD phenom(tm) 2 x2 555 processor 3.20 GHz
Installed Memory (RAM): 4.00GB (3.75 GB usable)
System type: 32-bit Operating system, x64- based processor
OS: Windows 10


Graphics Options
Resolution
: 1176x664
Quality: Fast
Depth of Field: Off
High Dynamic Range: On
Ambient Occlusion: On
Full Screen: on
Anti-aliasing: On
Gamma: 10%
Draw Distance

i have my pc screen is a 32" tv hdmi

i also uninstalled and reinstalled it sorted most of the problems out sorry for spelling i'm dyslexic trying to use spell checker
Are you not experiencing frame rate issues at all then? This thread is only for that.
 

bogieman987

Well-Known Member
Aug 13, 2014
87
77
420
26
Ireland
C - Poor frame rate is an issue that occurs when there's a lot of stuff happening, mostly when there's a lot of blocks moving or explosions with the occasional hiccup when driving along. Probably bottleneck due to my dated CPU.

Processor: Intel Core i7 960 @ 3.3GHz
Installed Memory (RAM): 16GB
System Type: 64-bit Operating System, x64-based processor
OS: Windows 10 Professional
GPU: Nvidia GTX 980

Graphics Options
Resolution
: 1920x1080
Quality: Fantastic
Depth of Field: Off
HDR: On
AO: On
Full Screen: On
AA: On
Gamma: 10%?
Draw Distance: 100%
 
  • Like
Reactions: Jamie

Cusuno

Well-Known Member
Apr 4, 2015
259
184
450
21
Germany
C - Not sure if this is considered as a frame rate issue or not, but the game always freezes for ~0,50 seconds from time to time whenever I go exploring, probably because it has to load/render the materials, textures and enemies which is very annoying (also happened with lower qualities).

Processor: Intel (R) Core(TM) i5-3330U CPU @ 3.00GHz (4CPUs), ~3,2GHz
Installed Memory (RAM): 8,2GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 10 Home 64-Bit-Version (10.0, Build 10240)

Graphics Options
Resolution:
1280 x 1024
Quality: Fantastic
Depth of Field: Off
High Dynamic Range: On
Ambient Occlusion: On
Full Screen: On
Anti-aliasing: On
Gamma: 10%
Draw Distance: 100%


Extra information:

DirectX-Version: 12
Video Card: AMD Radeon R7 200 Series
 
  • Like
Reactions: Jamie

XplosiveAsh

Well-Known Member
Sep 29, 2015
54
4
410
20
My lag always comes from the bosses that spawn constantly (not even in the bugged areas), or an overlybuilt tech shooting 100's of weapons at once causing an overload
Full screen res 1280 x 1024 quality fast high dynamic range off anti aliasing on Gamma 25% Draw distance 20% Windows 8 with 64 bit build 1.5.21.3 64-bit
 
Last edited:

NovaLegion

Jamie's best friend
Jul 28, 2015
617
553
500
19
My lag always comes from the bosses that spawn constantly (not even in the bugged areas), or an overlybuilt tech shooting 100's of weapons at once causing an overload
Full screen res 1280 x 1024 quality fast high dynamic range off anti aliasing on Gamma 25% Draw distance 20% Windows 8 with 64 bit build 1.5.21.3 64-bit
Please post in the format described in the original post.
 
  • Like
Reactions: Jamie

Chukklechode

Active Member
Dec 23, 2015
15
4
41
22
United Kingdom
B: Poor frame rate is a constant issue when playing TerraTech.
At the beginning of a world there is no lag at all, and it runs perfectly, but then it gets progressively worse the longer I play on a world.
Very frequently I come across salt fields that are litterally covered in enemy camps, most of which are fighting each other, and sometimes in areas of the deserts, when I clear out these camps, the lag decreases by a lot for a bit, presumably until another batch of enemies spawn somewhere else.


Processor: AMD FX(tm)-6300 Six-Core Processor (6 CPUs), ~3.5GHz
Installed Memory (RAM): 8GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 10 Pro 64-bit

Graphics Options
Resoultion: 1920x1080
Quality: Beautiful (I turn it down when the lag gets bad, but it rarely changes anything)
Depth of Field: Off
High Dynamic Range: On
Ambient Occlusion: On
Full Screen: On
Anti-aliasing: On
Gamma: 10%
Draw Distance: 100%
 
  • Like
Reactions: Jamie

streak1

Well-Known Member
Aug 30, 2015
2,291
2,141
570
23
steamcommunity.com
The newer unstable updates seem to be a lot slower, and I'm also noticing that the game takes a lot longer to load than it used to a couple of updates ago. The slowness might be because the draw distance slider isn't working right now, and I usually put it down pretty low. Could be something else, though. I also might be noticing that the game gets slower over time, but I am not sure about that.

I think it was usually around 30-40 FPS before, if I guess right. Now it's around 15-20.


Processor: AMD A6-6310 APU with AMD Radeon R4 Graphics 1.80 GHz
Installed Memory (RAM): 6 GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 10 Home

Graphics Options
Resoultion: 1600x900
Quality: Fastest
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: Off
Full Screen: On
Anti-aliasing: Off
Gamma: 10%
Draw Distance: 100%
 
Last edited:
  • Like
Reactions: Jamie

Tunerteen1023

New Member
Jan 23, 2016
2
0
2
24
question just bought the R&D DLC yesterday off stem how long dose it take after submitting my email to start using it.?
 

reaperx1

Crazed Builder
Feb 25, 2015
4,565
3,616
670
40
To use it on the forums to unlock the other areas, it may take a few days. Send a message to Saiwun and he can help you out.
In the actual game you will be able to use it right away. Just check out the R&D area and you will see.

Hope it helps

Have a good one
 

Jozroz

Well-Known Member
B: Poor frame rate is a constant issue when playing TerraTech.
C: Poor frame rate is an issue that occurs when it is night time.
C: Poor frame rate is an issue that occurs later in the game either as my base expands and/or as more and more enemies appear around the world..

Processor: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz
Installed Memory (RAM): 7.82GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 10

Graphics Options
Resoultion: 1366x760
Quality: Fastest
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: Off
Full Screen: On
Anti-aliasing: Off
Gamma: 10%
Draw Distance: 10%

P.S. @Jamie, finally did it! :D
 
  • Like
Reactions: Jamie
P

Pink Kitty

Guest
So, i have a problem that just popped up on 0.5.21.5

I'm getting 45-60 fps at the start of the game.
Been playing for an hour or so.
Small tech, little to no clutter

BUT... i get stutters.
little hitches every second or so.

I thought i had too much crap running in the background, so i rebooted, and cleared out all the crap.
Nope. even happens in R&D just driving a cab around.

It's really annoying.

dropping the graphics and draw distance did nothing, so i don't think it's my graphics card :(




Processor:
Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz
Installed Memory (RAM): 8GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 7

Graphics Options
Resoultion: 1920x1080
Quality: Fantastic
Depth of Field: Off
High Dynamic Range: On
Ambient Occlusion: On
Full Screen: On
Anti-aliasing: On
Gamma: 10%
Draw Distance: 100%
 
  • Like
Reactions: Jamie

Dr. Minovsky

Well-Known Member
Feb 13, 2016
17
11
105
41
We're looking to track down some frame rate/optimisations issues we've been having recently.
C - Poor frame rate when firing lots of weapons at the same time.

Processor: Intel Core i7 @ 2.70GHz
Installed Memory (RAM): 16GB 1600MHz DDR3
System type: 64-bit Operating System, x64-based processor
OS: OSX 10.11.3

Graphics Options
Resoultion: 1440x900 (half retina)
Quality: Fastest
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: Off
Full Screen: Off
Anti-aliasing: Off
Gamma: 10%
Draw Distance: 40%

Not sure if this is the right place or if the suggestions thread is, but here are a couple questions I'd ask if I was on the optimization team:

  • Am I pooling projectiles?
    • Firing lots of things at once kills my FPS down to slideshow mode regardless of quality setting and draw distance. Am I instantiating new copies of projectile prefabs or can I just have 1000 pooled and recycle them forever?
  • Am I substituting a lightweight hitscan/linear raycast for some projectiles instead of instantiating or recycling a mesh + collider [+ trail renderer] for literally every bullet?
    • The game's basic meta is to spam attack until enemy = kaboom. Maybe some users don't care about seeing literally every bullet arc out.
    • Can I LOD away luxuries like trail renderers if that's what my profiler fingers as the culprit?
  • Am I pooling terrain tiles and yielding the loop while poulating the new tiles?
    • It seems there's a lag spike (1 second) when new terrain tiles are instantiated, populated. Unity3D adds new objects to the physics simulation as a blocking operation, so I've noticed this a lot in my own infinite-tiled-terrain-based simulations. Instead of creating new tiles, can you just pool the same (tile radius * 2)^2 number of tiles and wipe/recycle them to avoid the physics spike? Maybe push tile population onto a separate thread or at least yield a populating coroutine to keep the frame rate up?
  • Can I beautifully fake multiple per-pixel lights using light cookies?
    • If a user wants to add multiple lights side by side, I can make a binocular-shaped light cookie and apply that to a single directional light between the two light meshes. Similar process goes for three lights in a row. This costs time in making several pre"baked" light cookies, but the computational savings is HUGE.
  • Can I beautifully fake an arbitrary number of diffuse lights added by users by just turning up the ambient light level at night and making the distance fog shader a little blacker overall + slightly more aggressive distance falloff rate?
    • Maybe my users don't all want a bunch of per-pixel lights pushing down frame rate. Maybe general illumination is quite fine.
  • For exploded objects arcing high into the sky [off-camera], am I destroying/sending back to pool everything that triggers OnBecameInvisible() ? Note I'll have to turn off shadows for exploding objects so the shadows engine doesn't keep these objects in the render queue.
  • Edit: Why, when my users are running in "Fastest" setting, are they still seeing anything mre detailed than a textured cube for stuff like the GeoCorp blocks and batteries, e.g.? Has any decimation been done for render-expensive meshes like wheels? Do I really need each tire tread nubby to be part of the mesh or can I just go smooth with a little texturing at low LOD levels?
  • Edit2: Why haven't I texture-atlased stuff like the GeoCorp battery indicator gauge instead of script-addressing child gameobjects for every pip in the gauge?
This is what I have off the top of my head. I'm very impressed with the game so far and I wouldn't be surprised at all if the programming team has already handled a bunch of these. There's always more [too much!] to do, of course!
 
Last edited:

Michael Kreitzer

Well-Known Member
Feb 25, 2016
55
13
415
38
B - Poor frame rate is a constant issue when playing TerraTech.

Gets progressively worse the longer the game. I start at maybe 45ish or so. Blocks don't seem to ever go away.. On a 20 hour game I barely make it above 10fps most of the time. I'm pretty sure I'm CPU bound.

Processor: Intel Xeon E5-1630v3 @ 3.7Ghz (quad core)
Installed Memory (RAM): 32GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 7 64-bit
GPU: Nvidia GTX 980

Graphics Options
Resoultion: 2560x1600
Quality: Any, makes no difference
Depth of Field: Off
High Dynamic Range: On
Ambient Occlusion: On
Full Screen: On
Anti-aliasing: On
Gamma: 10%
Draw Distance: 100%
 

Ole

New Member
Mar 24, 2016
1
0
2
C: Poor frame rate is an issue that occurs later in the game either as my base expands and/or as more and more enemies appear around the world..
Gets progressively worse the longer the game.

Processor: i7 @ 3.4Ghz (quad core)
Installed Memory (RAM): 6GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 10 64-bit
GPU: radeon r9 380x 4gb

Graphics Options
Resoultion: 1024p (19xx×1024)
Quality: Any, makes no difference
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: off
Full Screen: On
Anti-aliasing: off
Gamma: 20%
Draw Distance: 10%, makes no difference
 

harpo99999

Ah kick till it starts
Aug 14, 2014
2,234
1,131
570
australia
C poor framerate happens after approx half an hour playing

Processor: intel i3 3240 @3.4ghz/core
Installed Memory (RAM): 8GB
System type: 32-bit Operating System, x64-based processor
OS: Windows 7 ult
ssd boot drive that game resides on
Graphics Options geforce 430
Resolution: 1366x768 windowed on 1920x1080
Quality: Fastest
Depth of Field: Off
High Dynamic Range: On
Ambient Occlusion: On
Full Screen: Off
Anti-aliasing: on
Gamma: 10%
Draw Distance: 100%

noticed the debug log.txt files are getting very large in the game (30+mb in half an hour of play) and contain mostly errors of blocks/resources having NAN as position and or rotation values (have posted a seperate thread with attached logs/savegame from a three start of game, play till slideshow, save & exit, exit, copy debug log.txt, start game again cycle (the save was a fresh one in 0.60)
 

GroovySauce

Well-Known Member
Mar 27, 2016
3
0
103
Changing the settings from fastest to fantastic doesn't make much of a difference when the FPS are low maybe 10FPS

Windowed mode I loose a lot of FPS


B: Poor frame rate is a constant issue when playing TerraTech.

Game starts off with FPS 60+ on Max quality settings. Over time FPS gets worse and worse. Restarts of game and computer don't fix.

C: Poor frame rate is an issue that occurs when

Near starting base after playing for awhile and other medium to large techs.

Processor: Intel (R) Core(TM) i7 5280KCPU @ 3.30GHz
Installed Memory (RAM): 16GB
System type: 64-bit Operating System, x64-based processor
OS: Windows 10

Graphics Options
Resoultion: 1920x1080
Quality: Fastest
Depth of Field: Off
High Dynamic Range: Off
Ambient Occlusion: Off
Full Screen: On
Anti-aliasing: Off
Gamma: 10%
Draw Distance: 0-100%