Fresh install and not working "black screen"

Adriano

PAYLOAD STUDIOS
May 16, 2016
2,588
1,332
570
38
Hi @tom00729

Sorry you are having this issue. We're aware of it and are working on a fix.

In the meantime, this solution may solve your problem.

1) Go to your Steam Library, right click on TerraTech, select Properties.
2) In new window that opens, select the Betas tab.
3) Select version 1.3.5.
4) Once the update has applied, boot the game
5) Create a user profile when prompted.
6) Quit the game, repeat steps 1 & 2.
7) Select "NONE - Opt out of all beta programs"

Once the game has updated again, you should now be able to play the latest version of TerraTech, version 1.4.1.

This should resolve your issue. Please let us know if you continue to have problems.
 
  • Like
Reactions: Aardvark123

tom00729

New Member
Aug 15, 2020
2
1
4
Hi @tom00729

Sorry you are having this issue. We're aware of it and are working on a fix.

In the meantime, this solution may solve your problem.

1) Go to your Steam Library, right click on TerraTech, select Properties.
2) In new window that opens, select the Betas tab.
3) Select version 1.3.5.
4) Once the update has applied, boot the game
5) Create a user profile when prompted.
6) Quit the game, repeat steps 1 & 2.
7) Select "NONE - Opt out of all beta programs"

Once the game has updated again, you should now be able to play the latest version of TerraTech, version 1.4.1.

This should resolve your issue. Please let us know if you continue to have problems.
it has started working
thank you
 
  • Like
Reactions: Adriano