AI Allied techs unable to properly utilize propellers

Joined
Aug 25, 2019
Messages
30
Likes
19
Points
9
Location
Earth I hope
Website
www.youtube.com
#1
[Version Number][Platform] - AI allied techs unable to utilize propellers

Platform
PC

Game version


Frequency
Always Occurs

Game Mode
Tested in R&D, Noticed in campaign and R&D

Description
When using propellers or ion drives on an AI tech it seems unable to activate them, causing hovercraft to move considerably slower than expected. In the tested case the player controlled tech, without using its fuel boosters, Tops at 53mph and the AI tech when controlled tops at 77mph. When set to follow the tech moves considerably slower than the player-controlled tech. this measn tat the AI falls behind and eventually gets unloaded and stops following the player.

Steps to reproduce
Download the Aurora Bastion and Battle Cruiser below
Summon the battle cruiser and bastion and set the battle cruiser to follow/guard
in the R&D world simply align both techs in the same direction and fly the bastion straight wthout using the thrusters (dont press Ctrl)
You will then see the battle cruiser fall behind significantly
then controlling the battel cruiser, fly straight adn notice the higher speed
Additional files
Bastion -- https://steamcommunity.com/sharedfiles/filedetails/?id=1845394270
Combat Cruiser -- https://steamcommunity.com/sharedfiles/filedetails/?id=1845490224
 
Last edited:

NotExactlyHero

FORUM DEFENDER
Joined
Apr 9, 2017
Messages
1,021
Likes
1,400
Points
520
Location
Anywhere and Everywhere
Website
www.khanacademy.org
#2
Are you sure this is a bug?

To me this sounds like a simple case of the AI being the AI, as if I do recall correctly the AI, instead of being smart and holding down forward, taps forward instead.

Nice tech(s) by the way, although I think you may have put the same steam workshop link twice, assuming this is the battlecruiser.
 
Joined
Aug 25, 2019
Messages
30
Likes
19
Points
9
Location
Earth I hope
Website
www.youtube.com
#4
Nice tech(s) by the way, although I think you may have put the same steam workshop link twice, assuming this is the battlecruiser.
I fixed the links it mustve copyd the links wrong or i forgot to actually copy the combat cruiser link and put the same link twice.

This is correct. I would class it as unwanted behaviour though, so I think it's worth having it reported.
I understand the tapping of the forward control by the AI but it causes issues with various vehicles as the tapping also would slow techs down if they have airbrakes. I think it should be fairly easy to switch the control cheme over to holding it down.