[1.3] Fabrication AI hangs when reloading or returning to area

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,929
Likes
5,638
Points
675
Age
36
Location
UK
Website
www.youtube.com
#1
This is a relatively new crafting bug (not in my guide). I think it may require component factories, not sure how many levels thereof.

In 1.2 I'd noticed my crafting base hang in this same way while I was working on a build next to it, but I may have reloaded the save just before, not sure. Removing and re-adding any block seems to reboot the AI and get it working for me.

@Rafs was talking about this bug repeatedly on discord, but don't know if it's been officially reported there...?

So here, have a demonstration and a test campaign save:

 

Attachments

XeMurder

Active Member
Joined
Jul 24, 2019
Messages
1
Likes
2
Points
41
#2
So far this bug has been a perpetual problem for any kind of remote mining stations I try to set up.
The fabricator gets blocked up, stuck at 24/24, then the silos overflow and create a huge mess, meaning I have to baby sit the mining station, even though it is perfectly capable of defending itself.

I have a hankerin' for that Celestine (or whateve it's called).
 

AstraTheDragon

A dapper dragon
Joined
Sep 9, 2017
Messages
420
Likes
944
Points
505
Age
15
Location
Tír na nÓg
#6
So far there has been two independent reports of this bug on the Discord server. It seems to be quite a serious and widespread bug, but I don't know if it's been logged yet? @kae
I just wanted to stress its importance, in case the few reports on this thread made it seem like a minor fringe case.
 

Captain Load

Well-Known Member
Joined
Mar 8, 2016
Messages
537
Likes
451
Points
465
#7
Ah, so it wasn't just me. It's annoying to come back to a distant mine that you set up to neatly collect and process chunks only to find a giant mess. Frankly I wish we had the option to just attach manufacturing blocks directly to mines. Its not as if requiring that receiver or collector as a go-between is any kind of a time sink..in fact it allows you to use less blocks with clusters of mines.
 
Joined
Aug 25, 2019
Messages
30
Likes
20
Points
46
Location
Earth I hope
Website
www.youtube.com
#8
When returning to one of my mining setups the fabricators were showing as full but not spitting blocks out or absorbing(?) resources. thought all was fine just reset the recipes in the fabricators, however upon returning to my base my scrapper setup and crafting setup was showing the same thing, completely halting production and scrapping progress. this requires a fix of resetting the recipe by changing or canceling and requing the recipe. turning off repeat did not help. not really sure how to replicate it as its only happened once so far.
 
Likes: BenBacon

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,929
Likes
5,638
Points
675
Age
36
Location
UK
Website
www.youtube.com
#9
I've merged @Red Panda[Aurora Founder]'s new(ish) thread titled "Fabricators full ingredients when reloaded (GAMEBREAKING)" with this existing thread on the same bug. OK?

As noted above, you should be able to resume fabrication by modifying the tech in any way, I think (to avoid loosing resources already consumed by the Fabricator).
 

Poofer

New Member
Joined
Sep 6, 2019
Messages
2
Likes
0
Points
2
Age
28
Location
My House -_-
#10
Found this whle looking for a solution to the issue. In my case, altering the tech will NOT resume a full fabricator/factory, the only solution is to restart the process and lose the resources. Restarting the game, reinstalling the game or activating build beam and re-anchoring do nothing either.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,929
Likes
5,638
Points
675
Age
36
Location
UK
Website
www.youtube.com
#11
In my case, altering the tech will NOT resume a full fabricator/factory
Interesting. Could you upload your save file here in that case please (for the devs to potentially investigate)? See here for save file locations.

I suspect you might have a different type of crafting bug. Might be helpful to check my guide (if you've not already). You could also try popping off the fabricator itself, by removing the block holding it, then undoing. The progress is generally restored by undo.
 

Poofer

New Member
Joined
Sep 6, 2019
Messages
2
Likes
0
Points
2
Age
28
Location
My House -_-
#12
I sent via email, since i first found a steam thread, but here it is as well. I have since started to remove all my miner outposts and will probably scrap my crafting base for the moment and live off of invaders, at least until this particular bug is fixed.
 

Attachments

Joined
Aug 25, 2019
Messages
30
Likes
20
Points
46
Location
Earth I hope
Website
www.youtube.com
#13
I've merged @Red Panda[Aurora Founder]'s new(ish) thread titled "Fabricators full ingredients when reloaded (GAMEBREAKING)" with this existing thread on the same bug. OK?

As noted above, you should be able to resume fabrication by modifying the tech in any way, I think (to avoid loosing resources already consumed by the Fabricator).
I specifically removed any block that I could in hopes of rebooting it without unanchoring it and nothing worked
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,929
Likes
5,638
Points
675
Age
36
Location
UK
Website
www.youtube.com
#14
I specifically removed any block that I could in hopes of rebooting it without unanchoring it and nothing worked
Hmm, interesting. Maybe a different bug, or variant of it, then... If you could upload your save game, with the fabricator stuck like this, that would be great! :) (Save) file locations on Windows:
The general location for Save games and Snapshots are located below

C:\Users\*YOUR USER*\Documents\My Games\TerraTech\Saves\*YOUR PROFILE*

They are then placed in separate folders depending on their type
 

DunkMoose

New Member
Joined
Sep 12, 2019
Messages
7
Likes
0
Points
2
#16
Whenever I unload my base by going exploring or whatnot, all the fabricators that I have set to repeat craft anything break and lock up. Stating they have every material, but not spitting it out (e.g. 1/1 8/8 and 3/3, but not spitting out the block) What can I do to prevent this from happening and/or keep the chunks loaded?
 

DunkMoose

New Member
Joined
Sep 12, 2019
Messages
7
Likes
0
Points
2
#18
Yeah my version looks like the dude's from higher up. I have 11 GSO fabricators crafting each material into the GSO compressed variants, but when i go invasion hunting I have to scrap everything in the fabricators. I can't get a screenshot right now, but I can try later.
 

Matt

PAYLOAD STUDIOS
Joined
Jul 23, 2018
Messages
514
Likes
1,596
Points
305
#20
I've spoken to Ade about it who confirmed it's a known issue and is in the (ever-growing) list of crafting bugs to be fixed.

He wasn't able to say if/when it'll get looked at though.
 
Likes: Adriano