[1.3.12 - 1.3.7.3][PC] - Antigravs pretty much broken

burger1113

Well-Known Member
Jan 3, 2015
426
746
505
33
20200208224933_1.jpg

So, I loaded up most of my antigravs, and they all seem to have a few of their blocks unaffected by the antigrav bubble. :( It makes them tilt and sink to the ground, obviously.
Posting a save file below. I hope you can recreate the issue on your end.
Loving the Naval Cannon though. Cheers.
 

Attachments

Last edited:

RC-3197

Well-Known Member
Jan 5, 2018
61
243
435
According to the bug reporting guidelines, since I have this issue this post needs to be bumped

This issue is currently present in update 1.3.11 [stable].

Which turns the airship that took me forever to make into a useless paperweight:
1590119674715.png
This issue persists regardless of waiting to turn the anti gravity fields on using the switch or loading it in instead of switching it out. Also I could stick 200 anti gravity generators on those blocks and they still won't be effected by the anti gravity.

I really hope the developers can fix this bug, because these anti gravity fields are pretty much useless in their current state.

And just to clarify I was using only the 2x2x2 anti gravity generators.
 
Last edited:

burger1113

Well-Known Member
Jan 3, 2015
426
746
505
33
According to the bug reporting guidelines, since I have this issue this post needs to be bumped

This issue is currently present in update 1.3.11 [stable].

Which turns the airship that took me forever to make into a useless paperweight:
View attachment 32514
This issue persists regardless of waiting to turn the anti gravity fields on using the switch or loading it in instead of switching it out. Also I could stick 200 anti gravity generators on those blocks and they still won't be effected by the anti gravity.

I really hope the developers can fix this bug, because these anti gravity fields are pretty much useless in their current state.

And just to clarify I was using only the 2x2x2 anti gravity generators.
Yeah, with me pretty much depleting most of the build possibilities I could come up with in all the tech types except for antigravs, I don't think I would be coming back to this game until this issue is resolved... Building bigger antigravs that were self sufficient without external charging was really fun, and I was pretty sucked into them for a while. But the bug just got my OCD going like crazy lol Can't build a perfectly balanced tech when it won't balance even when it is built completely symetrically.

It's really too bad this can't be fixed, but I suppose it doesn't have the same urgency as some of the other things since Antigravs can be quite hard to make and get right, and you only get it at the end-game stage(meaning most players won't even bother with them).

Good thing I have Terraria 1.4 to keep me occupied.
 
Last edited:

RC-3197

Well-Known Member
Jan 5, 2018
61
243
435
The issue is still present in 1.3.12 [Stable]:
1591459589567.png
This bug really needs to be squashed, and it would be nice to have the developers say if they are looking into it or not.
 

Matt

PAYLOAD STUDIOS
Jul 23, 2018
751
2,496
505
So we've taken a look at this and everything seems to be working as intended.

It looks like you weren't getting the balance level and the thrust in-line with the mass to go in straight lines, as you it expected to. Some of the parts were only one line of blocks out but it is enough to make the Tech lean over.
 

Seth_Seth

doin stufs
Oct 14, 2017
1,794
2,695
525
I dunno
forum.terratechgame.com
So we've taken a look at this and everything looks to be working as intended.

It looks like you weren't getting the balance level and the thrust in-line with the mass to go in straight lines, as you it expected to. Some of the parts were only one line of blocks out but it is enough to make the Tech lean over.
Its bizarre for the anti-grav to seemingly just randomly ignore blocks in its range still
 

burger1113

Well-Known Member
Jan 3, 2015
426
746
505
33
So we've taken a look at this and everything seems to be working as intended.

It looks like you weren't getting the balance level and the thrust in-line with the mass to go in straight lines, as you it expected to. Some of the parts were only one line of blocks out but it is enough to make the Tech lean over.
The techs should still not be leaning to any side when they are just sitting still in ANTIGRAV, which IS happening(due to blocks not being affected by the bubble). They just fall to the ground, affected by GRAVITY.
Please, the color on the blocks you see on the screenshots should give it away.
They aren't purple.

IMG_20200612_021513.jpg
See? And no, they are not out of range of the antigrav bubbles... And when this tech sometimes loads in right, it does not tilt nor sink whatsoever.
Even blocks close to the antigrav engines get it, and it changes every time I load in the tech.
And no, this is a 'small' tech compared to what guys make around here, and is not a multitech either.

It may be that it occurs when it runs out of battery and flicks on and off due to battery being charged, but I found it happens at other times as well.
It's been pretty much half a year since I saw this happen for the first time and I'm pretty sick of all this, but I'm just over here hoping the best for the game.
And this is an issue.
 
Last edited:
  • Like
Reactions: RC-3197

Commander 86

Well-Known Member
Apr 2, 2019
36
90
225
So we've taken a look at this and everything seems to be working as intended.
If these are working as intended, then I'm a monkey's uncle!

Whenever I build or spawn in an anti-grav tech, there is about a 99% probability that some of the blocks will arbitrarily choose to ignore the anti-gravity fields, especially when there is more than one anti-gravity engine.

Don't believe me? I built this just to prove that anti-grav engines are still broken. Observe that the combined anti-gravity fields cover the entire tech.

Antigrav Glitch 1 Small.png

Now look here! The battery and the gyroscope on the underside of the hovercraft are unaffected by the purple aura of the anti-grav engines, this negatively impacts the tech's performance since the extra weight of these parts throws off its balance.

Antigrav Glitch 2 Small.png

Here's another example! This tech can't even get off the ground because all four of its batteries decided they didn't want to cooperate with the anti-grav engines today, the block next to the solar panel, the block under the radar, and both starboard gyroscopes are also not being team players.

Antigrav Glitch 3 Small.png

These malfunctions may not be entirely consistent, but anti-gravs are most definitely broken. Ignoring it is like burying your heads in the sand!
 

Zonko

Well-Known Member
Sep 20, 2019
206
150
240
'Cannot duplicate bug. Therefore there is no bug. If your vehicle doesn't balance, it's because you don't know how to build.'

this is your QA?
Wow. This is terrible.
 
  • Like
Reactions: RC-3197

J623

Well-Known Member
Jun 22, 2020
5
11
46
I also have this bug and I'm in the latest stable version (1.3.12).
1592849582052.png
This makes it lean to one side, which causes it to fly poorly compared to how it flew before the bug.