[1.3.11.1] Tech in Battle Arena Appearing More Than it Should

NotExactlyHero

FORUM DEFENDER
Apr 9, 2017
1,120
1,706
525
Anywhere and Everywhere
www.khanacademy.org
In the battle arena mode, this tech("Tank MKII") showed up about 15 times in a row, using the tech(Lodestone) below. It has been the only thing that spawned for me, and restarting the game/rnd only seems to work half the time, and as far as I can tell it only seems to happen with this tech.
Screen Shot 2020-05-28 at 4.58.07 PM.png

In these cases, this is seemingly the only tech that will ever spawn, as seen below, being after I killed around 7 of these. I suspect more would follow. Indefinitely.
Screen Shot 2020-05-28 at 5.43.02 PM.png
 

Attachments

  • Like
Reactions: BenBacon

BenBacon

Founder Of Bacon, Inc
Jan 15, 2017
1,555
2,235
525
Gulag
I think this is due to a lack of variety in the possible techs by cost range. When I use my expensive builds I seem to cycle between 4-5 of the same enemy techs, so this may not just be a bug, but just a bad implementation of a new feature. Your tech seems to be a bit cheaper than the ones I use, so there many unfortunately be only one in the price range of your tech.
 

NotExactlyHero

FORUM DEFENDER
Apr 9, 2017
1,120
1,706
525
Anywhere and Everywhere
www.khanacademy.org
I think this is due to a lack of variety in the possible techs by cost range. When I use my expensive builds I seem to cycle between 4-5 of the same enemy techs, so this may not just be a bug, but just a bad implementation of a new feature. Your tech seems to be a bit cheaper than the ones I use, so there many unfortunately be only one in the price range of your tech.
Half the time, it's the only tech I get, and the other half it does indeed cycle a bit. So sometimes I do get several techs in my 'cost range', and other times just the one tech.
 
  • Like
Reactions: BenBacon