[1.1] Missions stopped existing {none at trade station}

Duo

New Member
Joined
Apr 13, 2019
Messages
8
Likes
5
Points
4
#1
I am in version 1.1 and I'm pretty early in, as I just recently got the Venture license. Whenever I go on the mission board on the trade station no missions appear. So I thought, OK I'll wait 1 day and the missions will refresh, but that didn't happen. So I spent a few more days waiting, checking the mission board, and nothing. I also tried to save, reload, open and close the application, but none of this changed anything. I even went as far to check 5 other trading stations that were pretty far away, but there was no difference. I really hope I don't have to restart my save file since I put 17 hours into it and I really hope someone could help me.
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,390
Likes
4,438
Points
675
Age
36
Location
UK
Website
www.youtube.com
#2
Thanks for posting here @Duo, were you able to find your game save to upload here? (Drag and drop to post.)

From the troubleshooting FAQ, location may be:
  • For Mac:
    The file should be at ~/Users/YourUserName/Library/Application Support/TerraTech/Saves
 

Duo

New Member
Joined
Apr 13, 2019
Messages
8
Likes
5
Points
4
#3
Thanks for the reply. I really have no idea how to find the game save files, I've checked where you recommended but it brings up a page that has the files: Downloads, Public, Pictures, Music, Movies, Applications, iCloud Drive (Archive) and most importantly, *Brawlhalla Replays* In the applications file there is TerraTech but it isn't a folder, instead when I click on it, it just starts the actual game. I also tried to search online but haven't found anything I can use to find the game files. I've also searched for anything that has the name "TerraTech" in it on my computer and only found the application and nothing else. I did however find this file which is a bunch of numbers, I checked its contents and i believe that it is my save file or at least has my save files. I have a copy of this folder but I cannot attach it to the forum, it says "Oops, we ran into some problems!"
 
Last edited:

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,390
Likes
4,438
Points
675
Age
36
Location
UK
Website
www.youtube.com
#4
it says "Oops, we ran into some problems!"
There's a 1MB files upload limit. Save files alone are always below this. You could host the files elsewhere and link them, but... If you are able to properly search your computer (I don't know Macs), you should just be able to find "[You save name].sav" file.

The PC save file locations were moved not all that long ago, and I'm not sure the devs have updated the FAQ since, so I've no idea on Mac. But in "Documents\My Games" on PC, etc... Shrug. Thanks for making the effort. I'm sure QA dev @kae will be able to point the right way, come the start of the week.
 

Duo

New Member
Joined
Apr 13, 2019
Messages
8
Likes
5
Points
4
#5
I found the .sav file but it says when I try to upload it: "
Oops! We ran into some problems.
The uploaded file does not have an allowed extension."
What do I do now?
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,390
Likes
4,438
Points
675
Age
36
Location
UK
Website
www.youtube.com
#7
The uploaded file does not have an allowed extension.
Hmm, it should let you attach a ".sav". That is done a lot here. You've not opened the .sav file up, and are looking at the much larger content file, are you? Because the save file itself is a zip format.

compress it into a .zip file
You could try this, but shouldn't be necessary, unless your file is somehow over 1MB and zipping makes it smaller than that, or it has a different file extension...? You could also host the file on Dropbox, Google drive, or some other third party site.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,390
Likes
4,438
Points
675
Age
36
Location
UK
Website
www.youtube.com
#9
I got it to work
Oh, well done. Looks like the file extension was changed by having "copy" at the end, then (why the forum didn't accept it).

Anyway. I was able to get it to give me missions at the trade station. So there's some difference between PC and Mac or something else getting in the way.

2019-04-14 duo's 'Reload' no missions save.jpg

I took all four missions and resaved the game (attached to this post). So I don't know if that will get you permanently unstuck now, or not.

Did the tree in the background litterally just regrow compared to how it was when you saved? Seems to have flipped you bigger battle tech...

If you have further problems you could try packing up that base and going elsewhere. The location of anchored techs can cause other bugs, such as the weird terrain misplacement glitch. Shrug.
 

Attachments

Likes: Aardvark123

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,390
Likes
4,438
Points
675
Age
36
Location
UK
Website
www.youtube.com
#11
Do I just delete "Reload.sav" and replace it with your file?
There should be no problem having as many save files as you like in the "Campaign" directory.

I'd recommand manually copying your main save regularly (daily) to a backup, to keep it safe against any potential corruption (which should in theory be pretty rare).
 
Likes: Aardvark123

kae

PAYLOAD STUDIOS
Joined
Mar 7, 2018
Messages
526
Likes
624
Points
305
#13
Hey there Duo, are you still having this issue or can you let me know if you encounter this issue again after using Zero Gravitas' save file he uploaded?
 
Likes: ZeroGravitas

Duo

New Member
Joined
Apr 13, 2019
Messages
8
Likes
5
Points
4
#14
Oops, welp, I spoke too soon, so the 4 missions that I got were fun and all, though I couldn't finish the venture 40m jump one, I finished all the others and kept checking the trading station for 2 days but the missions didn't refresh, I removed my anchored techs but that didn't really help much. Here's my current save file.
 

Attachments

kae

PAYLOAD STUDIOS
Joined
Mar 7, 2018
Messages
526
Likes
624
Points
305
#15
Hmm strange, I'm finding missions on that save file testing on the Mac.

Can you try to verify the game files (you can follow the instructions below to do this) and then let me know if that works please?
Additionally can you start a new game or use another save file and see if you can find any missions there?

---

Verify integrity of game cache using the following steps:
  1. In Steam > Library, right-click on TerraTech
  2. Select Properties
  3. Select Local Files tab
  4. Click on Verify Integrity of Game Cache
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,390
Likes
4,438
Points
675
Age
36
Location
UK
Website
www.youtube.com
#17
@kae - In the Steam thread that kicked this off, another player is reporting this issue on PC: https://steamcommunity.com/app/285920/discussions/1/3570700856108732464/?tscn=1556087270

Another suggests that leaving one mission in the log will prevent the bug from kicking in (whether or not this is accurate or co-incidental, I have no idea).

Edit 2019-04-25: apparently not helpful, at least not for some.

Edit 2019-05-09: removed "[Mac]" from the thread title, as it's not a Mac specific issue. Also added "{none at trade station}", to clarify.
 
Last edited:
Likes: kae