[1.0] Twitter Integration?

Discussion in 'TT Stable & Console Bugs' started by Lost Ninja, Aug 29, 2018.

  1. Lost Ninja

    Lost Ninja Well-Known Member

    Joined:
    Jul 17, 2015
    Messages:
    1,191
    Likes Received:
    831
    I have no idea if this issue that I seem to be having is with TT or with Twitter. Or even if it's a bug and not a feature.

    In ze old days all this was fields... wait... in the old days once you signed in to Twitter through the game, you remained connected for at least a few sessions... I think it lasted for months though.

    Recently (from about 0.7 onwards) I have been complaining that the high end invaders have all been the same. But assumed that because I had logged in with Twitter that this was just down to bad luck and when I commented on this on the forums I was told that A)The included population of Invaders within the game files has been much improved and B)That nobody was terribly sure how much of the population was actually culled from Twitter anyway.

    Yesterday I built something I was pretty proud of (mostly for aesthetic reasons) and decided that I'd tweet it. I was a little surprised that it wanted me to log into Twitter as I though I had been. But after I duly logged in and Tweeted my Tech I pretty much instantly noted a marked improvement with population techs and an awesome improvement in Invaders. So clearly there is still some interaction between what appears in the twitter feed and what appears in game.

    Today I got an Invader that was the same as the one that I had been getting as the top tier Invader for months, but as I logged into Twitter (through the game) and authorised the TT App, it must just be luck that caused it to appear, right?

    Wrong it turns out that I was indeed no longer authorised through Twitter and I was getting stock Invaders again.

    So:
    1. Is this in fact a bug?
    2. If this is a feature can there be some sort of in-game check-box that shows the status of the Twitter Authorisation (or at least a prompt to sign in when starting a new game).
    3. And even if it's not a bug and there isn't an easy way to check the status of the connection (so no check-box) can you please update the list of in game populations more regularly, frankly for a game that prides itself on community interaction and features community creations (including my own :)) so prominently to not update these creations regularly is a farce.
    I don't often call on a deity dev but in this case an answer would be really appreciated.
    @Matt

     
    AstraTheDragon likes this.
  2. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,540
    Likes Received:
    2,552
    The Twitter connectivity had seemed patchy/broken for a long while, particularly with Sumo ladder techs not showing up.

    But I think there must have been some quiet work on that reliability issue, for 1.0, as I saw some Sumos from the QA devs, in the ladder, and I was able to reliably see other contenders I knew about.

    (De)authorisation probably a different issue... Maybe this thread should be in bugs if it's still happening? (Shall I move it for you?)

     
  3. Lost Ninja

    Lost Ninja Well-Known Member

    Joined:
    Jul 17, 2015
    Messages:
    1,191
    Likes Received:
    831
    Not sure if it's a bug or a suggestion, hence putting it in Open. So up to you.

     
  4. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,540
    Likes Received:
    2,552
    I consider that if it feels wrong, then it's worth making a bug thread about it. The "TT_Unstable" section is explicitly for "feedback", too, so targetted suggestions about an existing feature's function, why not...?:)

    So the main issue is that Twitter is quietly de-authorising itself for no good reason (when starting a new game)?

    Added "[1.0]" to title and move it from "Open" to "Bugs".

     

Share This Page