[1.0] 'Rotate Block Backwards' hotkey reassignment visual failure.

AstraTheDragon

A dapper dragon
Joined
Sep 9, 2017
Messages
343
Likes
772
Points
505
Age
14
Location
Tír na nÓg
Website
1drv.ms
#1
Noticed in version 0.8.2.4
After reloading the game since resetting the controls (such as after updating it with Steam) the rotate block hotkeys will be reverted to:
Rotate Block Forwards: F
Rotate Block Backwards: G

Attempting to modify 'rotate block backwards' will result in that cell (usually showing the hotkey) blanking. This goes for both cells beside 'rotate block backwards.' While blank, the last set hotkeys will still function as usual.

Steps to take to view this issue:
1. Reload TT after resetting the controls (such as after updating it with Steam.)
2. Open the controls menu and try to rebind 'rotate block backwards'
3. Notice the cells blanking.
4. Try to rotate the block using the hotkey you set (but saw no visual feedback for.)
5. Notice how that works.

Incidentally, after I closed the game by pressing the 'x' on the bar at the top (it was in windowed mode) it crashed. I have appended the log to this post.
 

Attachments

Likes: ZeroGravitas

AstraTheDragon

A dapper dragon
Joined
Sep 9, 2017
Messages
343
Likes
772
Points
505
Age
14
Location
Tír na nÓg
Website
1drv.ms
#2
Excuse this comment but as far as I can see this has not been noticed. As it remained from [0.8.2.4] to [1] , I will need this to be moved into #Bugs (Stable Only)
 

AstraTheDragon

A dapper dragon
Joined
Sep 9, 2017
Messages
343
Likes
772
Points
505
Age
14
Location
Tír na nÓg
Website
1drv.ms
#3
I have noticed since last posting on this thread that reassigning the 'rotate block backwards' hotkey doesn't wipe previous assignments, so now half my keyboard rotates block backwards... :( I also tested this issue with a number of different resolutions and it seems universal.
 
Likes: ZeroGravitas

kae

PAYLOAD STUDIOS
Joined
Mar 7, 2018
Messages
435
Likes
542
Points
205
#5
Heya, were aware of the initial bug report about the cell turning blank and we should have it fixed up soon!

I don't see a reason why we don't unbind keys which have been rebinded to another action, I'll forward this on to the rest of the team.

Cheers!
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,051
Likes
3,843
Points
675
Age
36
Location
UK
Website
www.youtube.com
#6
I will need this to be moved into #Bugs (Stable Only)
I (we) don't tend to move threads around based on the version they've most recently been seen in, seeing as there's hundreds of outstanding reports. Leaving the original patch number in the title, etc, give a concrete indication of a version that the bug was seen in (good enough for retesting, etc, I think).

Edit 2018-08-14: just reported on Steam too, here.
 
Last edited:

layer1

Well-Known Member
Joined
Jun 14, 2017
Messages
237
Likes
291
Points
470
Age
58
#7
Rebinding this key results in the 'Rotate Block Forwards' key being rebound instead.

Pretty simple bug: Open options->Controls and try rebinding the key.

Letter 'i' is also hard bound to something and cannot be used but that's what autohotkey is for.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,051
Likes
3,843
Points
675
Age
36
Location
UK
Website
www.youtube.com
#8
I've just merged @layer1's new thread titled "[1.0?] Cannot bind 'Rotate block backwards'" with this one, which I've moved over from "TT_Unstable", for better visibility....

(Yes, I know. Just this once, though... I left a permanent redirect there too.)

Please let me know if you think I've miscategorised it, and these are separate things.