[1.0.1.3] Tech Loading menu bugs & issues (again, more)

Discussion in 'TT Unstable Bugs' started by ZeroGravitas, Dec 5, 2018.

  1. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,929
    Likes Received:
    3,532
    This kinda follows on from my report on this menu in 1.0.1.2, but a lot has been changed around, and theres a bunch of new issues, so I've started a new thread.

    Still true. This is a real problem, especially given it's interaction with the other issues, below.

    (2) The scroll bar position no longer seems to carry between tabs, but you can't scroll down in the Steam tab while it's loading snapshot thumbnails. Not with the default sorting options anyway (by Creation date, descending - think those are default). [1m06s in first video.]

    (3) When you have the "Show Advanced Option" section open the content of that gets pushed off the bottom of the screen by the "Cannot deploy" warning message (can just see the search bar, which is still usable).


    Sorry, this video is not very task focused.

    (4) You can't right click interact with anything in the world while the load menu is open. What's the point in having it off to the side if other interactions are going to be blocked? May as well put it in the middle of the screen, as it was.

    (5) WASD (and arrow keys, etc) are intercepted by the menu, scrolling through selections, etc. I guess that's necessary for console compatibility, but it's horrible for (PC) gameplay, in that you have to fully close the menu just to shuffle over your current tech a little, can't provide a little control input to keep it from rolling away, or quickly killing a little enemy with [Space] or picking it up in build beam. And drive/fly-by turret drops, etc, are now completely out of the window (they were fun).:(

    (6) You can't press [Tab] to quickly close the load menu as we used to (I used to - opening and closing inventory briefly). Or [Esc]. However, you can click to anchor/unanchored and take snapshot overrides it, but then returns to the menu. Mission log overrides and then closes it (very inconsistent).

    (7) You can lock yourself out of the advanced options section, even while selections are made within that section. This is the worst bug with it so far. e.g. by bringing up the "View Tech Blocks" information and then switching tab.

    I was able to restore access by going back and selecting a tech I was able to deploy and triggering the "Cannot Deploy" warning messages:



     
    #1 ZeroGravitas, Dec 5, 2018
    Last edited: Dec 5, 2018
    Galrex, AstraTheDragon and harpo99999 like this.
  2. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,929
    Likes Received:
    3,532
    (8) There's no way to view the blocks you are missing (to load a tech), while also browsing the Trading station or Payload terminal shops. For my liking, I'd say this is a big enough issue to justify moving the whole tech loading menu (yet again). e.g. so that it slides down from the top of the screen, or more simply, is on the right of the screen instead (a little weird as that might feel), so it can be up at the same time as the inventory on the left.

    You could make the missing blocks preview pop-out instead, e.g. as a bar to the right of the new loading menu, that can stay open while viewing shop inventory. Having to close out of the load screen, open the shop inventory, then go back to load, re-open the missing blocks view, etc, for each new block you need of a dozen or so, is pretty exasperating. A semi-work around option would be via...:

    (9) I'd still really like a quickload/hotswap bar (I'm hoping this is in the works), in which we can manually insert our most used techs. Allowing placement with two key presses and a click (eventually): open hotswap bar (e.g. [T]), select tech (e.g. numbers 1-9), LMB to deploy tech, or double tap the number/thumbnail for tech replacement loading (for example).

    This bar could pop in from the top of the screen and have a (wide) missing blocks dialogue underneath it, letting you see those while shopping at the same time (as an alternative to other things I suggested in point 8).

    ----

    (10) "Swap Tech" loading (in R&D/Creative):

    (a) Seemingly doesn't account for the size of the new tech, so will still still cause tech intersection when loading far bigger techs (while next to another tech)

    (b) "Too Far Away" failure while airborne, because it wants to deploy to the ground, instead of actually replacing the tech. Maybe you want to limit this purposefully, but it's confusing, and a nuisance for airships/hoverships, etc, especiall if they have no (easy) way to get back down to the ground (e.g. functional anchors underneath, which will teleport you back down).

    (c) "Position Blocked" from any tiny little block (or resource?) in the vicinity, or hidden inside your current tech (very confusing when you can't find the problem). I'd argue that you might just ignore loose blocks (unless there's a *lot* of them, or they are the biggest type, right inside the tech footprint).


    Again: @TheFuntastic, right? Plus @kae, @Adriano, @Sammi, etc.

     
    Galrex, AstraTheDragon and harpo99999 like this.
  3. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,929
    Likes Received:
    3,532
    1.0.1.4 update:
    Can now drive around with menu open. Feels much freer, thanks.:) (No right-click menus though.)

    Oh cool, now you can, in 1.0.1.4.:)

    I actually noticed, afterwards, that this worked *sometimes*. It looks like now it only closes the menu of the Advanced Options are hidden.

    Now it seemingly does. Nice.

    All the other mentioned bugs seem unchanged for now.

     
    Galrex and NotExactlyHero like this.
  4. kae

    kae PAYLOAD STUDIOS

    Joined:
    Mar 7, 2018
    Messages:
    348
    Likes Received:
    437
    Heya ZG, thanks for the lengthy post on the tech loader, I still prefer separate posts for each issue as it's easier to track whats been logged and fixed already in our internal database , though with so many issues listed I can see why one wouldn't want to :p

    So to go through the list.

    1) I've still not managed to reproduce this on this side, each time I open the menu and switch out the game goes back up to a normal stable frame rate after a second or two, could you provide an up to date DxDiag please?, I can only find one from September 2017.

    2) Will log

    3) Already fixed internally

    4) Will log

    5) Fixed

    6) Fixed

    7) Will log

    8) More feedback than a bug, but I'll bring it up with the team

    9) We haven't forgotten

    10.a) Should be better in the next build, this one's quite annoying to get right and we'll be tweaking this as we go.

    10.b) Feed back, will look into it and see what we can do

    10.c) Same as 10.a

    Cheers

     
    ZeroGravitas likes this.
  5. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,929
    Likes Received:
    3,532
    Attached. My PC is a good desktop with NVMe SSD, good wired Virgin broadband, etc.

    Funny... I take it you also have a whole lot of Steam workshop subscriptions too, then?

     

    Attached Files:

  6. kae

    kae PAYLOAD STUDIOS

    Joined:
    Mar 7, 2018
    Messages:
    348
    Likes Received:
    437
    Hundreds :)

    Hmm as I expected I don't see anything from your DxDiag from a glance that could be a problem, do you mind reproducing the lag and then throwing us the output log too?

    Thanks!

     
    #6 kae, Dec 10, 2018 at 12:10 PM
    Last edited: Dec 10, 2018 at 12:18 PM
  7. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,929
    Likes Received:
    3,532
    Here (attached) - just loaded the unstable, new Creative game, load tech Steam tab, closed menu (still low FPS and stutter), then opened it and went back between tabs one more time before exiting game.

    Trying to think about what differences there could be between us, I wondered about cloud sync, which I have turned off. Going to try it with it switched on, when it actually finishes re-syncing....

    Edit: It didn't make a difference for me, shocker. So just another mysterious difference, like my lack of distance fog, I guess.

     

    Attached Files:

    #7 ZeroGravitas, Dec 11, 2018 at 2:22 AM
    Last edited: Dec 11, 2018 at 2:41 AM
    kae likes this.

Share This Page