[1.0.0.3] Enemy capture base multi-tech disintegrates on bolt deployment

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,411
Likes
4,485
Points
675
Age
36
Location
UK
Website
www.youtube.com
#1
Testing the "Take Rebel Station" grade 5 mission for it's new base tech population (it's really cool to see our techs turning up here :)).

However, the 4 arm sections of my "Umbrella" mutli-tech base (snapshot attached) all disintegrated when the bolts blew:

Save attached for re-testing.

Obviously it should have cabs in each arm. I'm seeing no signs they were detached, in the debris, so assuming they self destructed (or were removed in the snapshot after submission).

I've just re-tested it as deploying fine multiple times in Creative mode, so I don't know what's happening there.

I'll re-run the save pre-mission collection, to try to see if any other of the base techs have this issue....
 

Attachments

Last edited:

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,411
Likes
4,485
Points
675
Age
36
Location
UK
Website
www.youtube.com
#2
Lathrix got this tech as a capture base, apparently, and noticed the random disintegration (18m58s):


@kae - any chance this falls under the umbrella (;):p:oops:) of a larger issue that will be addressed (soon)? I'm assuming 1 tech's not a priority. Do you guys know why this is might be happening?

I've re-checked and it self deploys fine in R&D, when I set it to be an enemy. Do enemy techs in campaign somehow have a lower processing priority, in some why, that would make this more prone to the tech splitting disintegration bug? (Or some relative of it.)
 
Last edited:

kae

PAYLOAD STUDIOS
Joined
Mar 7, 2018
Messages
526
Likes
624
Points
305
#3
Hmm this doesn't look like anything we've got logged. It looks like the tech only explodes when it is controlled by the AI.

I'll look into this, cheers ZG!
 

Simon

PAYLOAD STUDIOS
Joined
Oct 1, 2018
Messages
17
Likes
61
Points
115
Age
47
#5
Hi ZG. The game thinks the dropped arms are incapacitated enemy techs as they have no weapons, wheels, etc. For this reason they decide to self destruct. To fix it I've made it not self destruct if it has any item holders (conveyor belts, receivers, etc.) on it as that implies that it's a base. This should be in the next stable release.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,411
Likes
4,485
Points
675
Age
36
Location
UK
Website
www.youtube.com
#7
OK, so retesting this in 1.0.1.6, the arms now stay intact! Nice.:D



However, they remain as enemies after the mission is completed... Something I was worried might happen, when talking about multi-techs for this project, with @zanzistar.

This is an old save, though, so maybe if the enemy base was spawned in in 1.0.1.6, it would work...? (X to doubt.)

Re-oriented cab build beam bugs still in operation, too: