[1.0.0.2] Fan noise stays silent after interrupting sounds abate

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,543
Likes
4,662
Points
675
Age
36
Location
UK
Website
www.youtube.com
#1
I think it was a performance 'optimisation' to reduce the number of simultaneous sound effects playing, making it sound fairly awful as loud mechanical noises are totally silenced by the hum of one distant engine, etc. But aside from that, I've been continually getting the issue that fan noises do not resume after being silenced in this way.


Demo tech attached - the lowest number of cluster missiles I could have to make this happen reliably. Works anchored or flying, etc.

(Yet) another superficial little glitch during filming - I repeatly fell out the air and crashed because I was letting the fans on my "dropship" (attached too) totally spool down, to re-engage the sound effect after firing...

I'm not sure of the overall specificity of the bug, but I think it happens with all fans/props, at least.
 

Attachments

Last edited:

Sdarks

PAYLOAD STUDIOS
Joined
Jun 13, 2018
Messages
241
Likes
394
Points
270
Age
25
#3
Looks like the sound optimisations are working as expected, it's just that the fan noise never checks if its sound is playing and never tries to play the sound again if it got culled :)
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,543
Likes
4,662
Points
675
Age
36
Location
UK
Website
www.youtube.com
#4

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,543
Likes
4,662
Points
675
Age
36
Location
UK
Website
www.youtube.com
#9
Just fixed this.
Oh wow, well done, no cut out at all now in 1.0.2.4! Even with my most fan and missile spammy tech! Nice. :cool:

So there wasn't a limit on the number of concurrent sounds, to preserve performance? It was just a bug?

I noticed now that in creative mode spawn, the starting techs no longer have ambient engine noises. That is, except for the venture rocket car and the hover ring sound (those rings continue to make humming even while turned off, by the way). Was this a (deliberate) change?
 
Likes: kae