[0.8.2] Hawkeye Large Armour Plate Fabricating

Discussion in 'Community Help, Questions and Guides' started by Heslion, Jul 7, 2018.

  1. Heslion

    Heslion New Member

    Joined:
    Jul 7, 2018
    Messages:
    2
    Likes Received:
    3
    Encountered an issue when attempting to craft an Hawkeye Large Armour Plate. Selecting it from the Hawkeye fabricator with two GSO Component Factories attached to the conveyor results in both factories requiring the materials needed if available from my silos, The second factory used for making the advanced components has no problem receiving its materials, however the first factory used for making the basic components for the second factory only accepts the luxite for creating the greebles and lets all the plumbia ingots pass it. Additionally, about three times the needed luxite and plumbia is taken from the silos after the first factory has received its luxite and the second factory has received its plumbia, even though all that is needed is two plumbia ingots for the first factory. Oddly enough when I manually crafted a single greeble and left it on the conveyors and then ordered a armour plate, the process worked entirely without issue, with the first factory creating the second greeble with no problems. When removing the first factory and leaving only the second, ordering a armour plate results in the second (And now only) factory not responding or requesting any materials. Then tried ordering a medium plate, and the process worked without issue. Tried ordering another large plate afterwards and once again it did not respond. A solution is to have a factory constantly making greebles, but obviously that isn't very efficient, and since I can't set how many I would like it to create, it would end up making too many, and unnecessarily requires another factory for the rest of the basic components for automated production.

    Edit 1:Introduced a third factory to create a Helios AI sentry, worked fine, then attempted to create a seeker pod, the problem occurred once more, this time with olastic bricks. Process worked smoothly up until it needed to create a fuel injector for the cyclone jet for the thermo jet, and refused to receive the olastic. However, it had no problem creating the fuel injectors needed directly for the seeker pod. Once again, there was much more carbius and olastic on the conveyor than was needed(3 and 11 respectively, although I'm fairly certain I've seen even more elastic being moved onto the belt(Yep, it's moving olastic on and off the belt, it's now at 9)).

    Edit during edit: Changing the conveyor direction caused the factory to accept the olastic, presumably because it is now being moved to silos instead of being sent to any other factories. Still not ideal if you want to set your fabricator to create blocks while you're away.
    Going to attempt creating a large armour plate with conveyors reversed.

    Edit 2: Attempted to create a large armour plate with four factories (required for finishing the seeker pod) and while I thought at first the problem had occurred again, but after waiting for the resources to around (Reversing the direction makes all resources take much longer to get where they need to go) they eventually reached their destinations. What I did notice while creating the seeker pod was the issue seems to occur when two machines request the same resource, but only with certain materials, as the machines had no problem when requesting fibron chunks at the same time. To note, the conveyors were going counter-clockwise when the problems occurred, and clockwise when the process worked smoothly.

    Edit 3: Moved factories to opposite side of fabricator to increase efficiency since alternator conveyors won't work, and now the issue is once again occuring. Reversing the conveyor to counter clockwise fixed the problem for the current craft, but the issue occurred again, with one machine refusing plumbia, and another refusing fibron chunks. Reversing again to clockwise fixed the problem. Going to try crafting with all dongle types on each of the factories and hope they somehow work things out efficiently and without breaking.

    Edit 4: Crafting clockwise didn't work, reversing didn't fix. Crafted counter-clockwise, worked, repeated to see if it was just chance, it failed. I don't know what the game wants from me anymore.

    Sidenote: While fabricators do not realize they are requesting too many materials, alternator conveyors do, and freeze the extra materials above them as they come across, blocking the belt.

    Screenshot of single factory not responding: https://steamcommunity.com/sharedfiles/filedetails/?id=1434537725
    Screenshot of four factory setup refusing resources: https://steamcommunity.com/sharedfiles/filedetails/?id=1434879216
    Screenshot of working four factory setup: https://steamcommunity.com/sharedfiles/filedetails/?id=1434879202

     
    #1 Heslion, Jul 7, 2018
    Last edited: Jul 8, 2018
    Lord Zarnox likes this.
  2. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,746
    Likes Received:
    3,040
    OK, so it looks like you only have 1 Component Factory there, currently - this will only work for automatically making blocks with just the lowest level Components. Each additional tier of Component requires you to have an additional Component Factory (so 4 needed, at minimum, to make anything with Exotic components, like HE missiles for example).

    See my crafting guide on steam (section 7's about component factories).

    I've moved this thread from "Bugs" to "Community Help", for now (although I didn't manage to read the whole block of text to be sure there's no glitches happening too...).

     
    Lord Zarnox, Heslion and JimmyBlether like this.
  3. Lost Ninja

    Lost Ninja Well-Known Member

    Joined:
    Jul 17, 2015
    Messages:
    1,191
    Likes Received:
    843
    It sounds like the bug where some resources requested by factories just don't go into the factory, I always (so far) have found that reversing flow of parts one way then back (so reverse main conveyor then back to normal) will fix it at least temporarily. But the text describes a bug, which I think has been reported (has an existing thread) in the past and seems at any rate to be fairly common.

     
    Lord Zarnox and Heslion like this.
  4. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,746
    Likes Received:
    3,040
    Still can't digest the wall of text (I know, I know, I'm one to talk...), but from pics:

    • Make sure to remove and re-add the fabricator after making any modifications to the crafting layout, to avoid extra spurious resources sent to the component factories.

    • Make sure there's one component factory with no dongles at all (the first in the line). Dongly placement is less sensitive if you have 5 or 6 component factories (but don't add more than that on a big conveyor loop like that.

    Yeah, crafting's so full of weird bugs that you are rather limited with what will work (well).:rolleyes:

     
    Lord Zarnox and Heslion like this.
  5. Khaine

    Khaine Well-Known Member

    Joined:
    May 29, 2018
    Messages:
    203
    Likes Received:
    181
    1) If you're experiencing "overfeeding" or "factory blindness" issues your cleanest option is to put a dropper at the end of your assembly line. Whatever resources aren't used just drop out and cease to clog up the production process.

    Then put a resource receiver, 11 fabricators and a SCU next to that and just craft the spillover back into blocks. This will let you regain some control over the production process until you figure out what's wrong with the system.

    2) You can also do a forced feeding option. Make it so the product generated at the exit point from component factory 1 (ore+ore for component) has nowhere to go but into the entry point of component factory 2 (ore+component for higher component). This helps the system plan the production better and tends to reduce problems.

    PS: Unless you're going for an absolutely minimalistic design I'd recommend at least 7 component factories as an all round sweet spot. You've certainly got the room on that setup.

    PPS: I was actually using 12 component factories (forcefed in pairs) and two different conveyor belts to make Hawkeye armour at two different fabricators simultaneously (all connected within the same industrial complex). Some overfeeding did happen at times but with the right system in place you won't even have to do anything about it.

     
    #5 Khaine, Jul 8, 2018
    Last edited: Jul 8, 2018
    Aardvark123, Lord Zarnox and Heslion like this.
  6. Heslion

    Heslion New Member

    Joined:
    Jul 7, 2018
    Messages:
    2
    Likes Received:
    3
    Thanks for the replies, tried making another crafting base (Probably over complicated) with all of your tips before just giving up on trying to figure it out and just picking up ZGs CompactAllCrafter, which is working perfectly, hopefully I can make some ridiculous monster the way I want it as the game gets updated. I also read you can use four auto miners at a time for a single seam from ZGs guide, so that's fun, and I'll use that money for the compressed resources.

     
    #6 Heslion, Jul 8, 2018
    Last edited: Jul 8, 2018
    Lord Zarnox and ZeroGravitas like this.
  7. Khaine

    Khaine Well-Known Member

    Joined:
    May 29, 2018
    Messages:
    203
    Likes Received:
    181
    I'm not sure if the devs already patched out the 4 miner thing or not. I couldn't get it work when I tried it.

     
  8. Galrex

    Galrex Possibilist

    Joined:
    Oct 31, 2017
    Messages:
    182
    Likes Received:
    341
    It should definitely work. Why would they remove it tho?:confused: Just get a cab and attach 4 autominers like below:
    4x Autominer.png

    Spawn and switch tech then enter build beam mode so you can move it just right above the seam then anchor. All 4 should be working after repeated anchor deanchor. Still couldn't understand why would the devs patch them out. :D

     
  9. Galrex

    Galrex Possibilist

    Joined:
    Oct 31, 2017
    Messages:
    182
    Likes Received:
    341
    Unless... there's a BuG. :confused::confused::confused:

     
  10. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,746
    Likes Received:
    3,040
    It's fiddly, hence me making a video tutorial on how best to deploy them. It's a little more fiddly to position exaclty now, too, sinse the build beam got a speed buff after I made my (1 Million Block Buck) vid.

     
  11. Zed

    Zed Well-Known Member

    Joined:
    Dec 23, 2016
    Messages:
    1,256
    Likes Received:
    1,187
    As an alternative to the all crafter the Yaff 1000 is also capable of creating all blocks effectively and efficiently without the need to swap fabricators / scrappers and uses a tried and true looped conveyor method.

     

Share This Page