[0.8.1] Wheels get stuck randomly

Voideka

Well-Known Member
Joined
Feb 2, 2017
Messages
6
Likes
3
Points
205
#3
Using Behemoth Wheels in R&D I destroyed and drove over the resource area, which caused the suspension on the Behemoth Wheels to change orientation from up/down to left/right.

I am able to repeat this consistently in this area, however simply driving over the rumble strips on the other side of the R&D chamber does not seem to have this effect. I believe this is either because of the collisions, or from driving over the resource chunks, which provide a more challenging terrain due to their movement.

A video demonstration can be found here:

Windows 10
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,493
Likes
4,584
Points
675
Age
36
Location
UK
Website
www.youtube.com
#4
Likes: BenBacon

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,493
Likes
4,584
Points
675
Age
36
Location
UK
Website
www.youtube.com
#6
I've merged @Deutsche Würfel's new thread titled "Broken Springer wheels", from the "TT Unstable" section, with this existing thread on the same, general, wheel bug.


While here, I'll note that @DerNiepe showed me that the front wheels on a tech will tend to spin backwards when player's pushing the tech against a transition to a steep incline. (Wheels be messed up at the moment, with ground clipping, wonky asymetrical steering, etc too.)


Edit 2018-06-13: see also:
If this is a new issue, then I'm wondering if it is down to the new problems with wheels locking up and so failing to register contact: when I just tested this all 4 of my wheels locked and clipped through the platform every time. Steering axis messed up like this, too:

 
Last edited:

Zorgomol

Not a Number
Joined
Apr 9, 2018
Messages
191
Likes
331
Points
270
#7
I have had cases where the Behemoth wheel orientation flips entirely (upwards rather than downwards) and the same thing sometimes even affects GC Middle Tracks which stop giving any support or traction. It makes things difficult when you're trying to drive a rather large mobile base through mountains...
 

Sporked Spoon

Well-Known Member
Joined
Jun 25, 2016
Messages
55
Likes
73
Points
420
Location
Space
#9
Strange thing I've noticed while playing through a new save, it seems sometimes certain wheels (possibly all of them) suddenly go limp or "dead". So far I've seen this in the GSO Dirt wheels, GEO Jaws wheels, and even in GEO's tank tracks:

20180617011953_1.jpg (middle tread wheel should not be hanging to the left like that)

While at first this seems like a simple visual bug, it really isn't. Letting it be and then gaining 2 or 3 "dead" wheels does start to affect your Tech's performance, as the dead wheels are dragged along instead of helping the normal ones push your Tech forward.

Also, after some testing, I've come up with a theory that the wheels "dying" is caused by getting jostled around too much from driving over rubble from destroyed rocks. However, I'm not at all certain of this.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,493
Likes
4,584
Points
675
Age
36
Location
UK
Website
www.youtube.com
#11
I've just merged @Sporked Spoon's new thread (from TT Unstable section), titled: "[0.8.1.1] "Dead" Wheels" with this existing one on the same issue that the devs have got logged already. (And are hopefully prioritising a fix for, because it's massively prevalent, irritating and unavoidable.)

Same, I would say.:) (They should make you a mod so you can merge these yourself, @QuackDuck.;))

I suspect it has something to do with the wheel vibration fix.
Ahh, that makes sense - I hadn't noticed that the jittering has stopped.
 

Zorgomol

Not a Number
Joined
Apr 9, 2018
Messages
191
Likes
331
Points
270
#13
Just for fun, take a look what happens to the wheel when you do a 360 turn in build beam. It can be mystifying to some and enlightening to others... ;) It is particularly visible with Behemoth wheels.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,493
Likes
4,584
Points
675
Age
36
Location
UK
Website
www.youtube.com
#14
In the R&D ramp test I did earlier, I'm no longer seeing this problems of wheels getting jammed:
If this is a new issue, then I'm wondering if it is down to the new problems with wheels locking up and so failing to register contact: when I just tested this all 4 of my wheels locked and clipped through the platform every time. Steering axis messed up like this, too:


They still jiggle like crazy on resources and rock seams, of course. But is anyone seeing the jamming problem any more?
 

layer1

Well-Known Member
Joined
Jun 14, 2017
Messages
239
Likes
292
Points
470
Age
59
#15
I did a bazillion attempts through that stupid loop today and the wheels didn't hiccup once, which was nice because I had to keep running away from nearby spawns that kept chasing me.