[0.8.1] Steam (app already running)

Joined
May 26, 2018
Messages
2
Likes
2
Points
4
Age
21
#3
First I exited steam (meaning right click and select "exit steam" on the taskbar or ending the background processes too, not just exiting the window). Then I deleted my "appcache" folder in my Steam files, then I restarted my computer. I know appcache can cause problems if apps don't function correctly with steam or if steam doesn't clear it out properly due to a crash or otherwise, and deleting it will cause apps on steam to "restart" like clearing out ram on your computer. It hasn't happened since and I don't know what caused it the first time, but I hope this helps
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,307
Likes
4,255
Points
675
Age
36
Location
UK
Website
www.youtube.com
#4
Oh cool. Thanks for replying quickly.:) So it could well have been a game bug that the devs need to figure out, then...?

I'll pass this solution on to the person reporting this on Steam.
 

Soviet_Samuelson

On the path to becoming a grand-master idiot
Joined
Feb 9, 2018
Messages
1,767
Likes
1,297
Points
325
Location
My box
Website
forum.terratechgame.com
#5
this whole thing is an issue with all of steam, not terratech. Put a complaint on their website (i won't because i have the attention span of a small paleocene rodent)
 

Lost Ninja

Well-Known Member
Joined
Jul 17, 2015
Messages
1,208
Likes
859
Points
520
Age
43
Location
Yorkshire Dales under a rock.
#6
Basically when I shut the game down the game continues to show as running in steam. I cannot relaunch the game without exiting and relaunching steam as well.

Not 100% sure this wasn't the case in 1.0 but if it was I didn't notice.

There is no sign of TerraTechWin64.exe in my running processes.
 

Attachments

harpo99999

Ah kick till it starts
Joined
Aug 14, 2014
Messages
2,038
Likes
981
Points
570
Location
australia
#8
I also have a memory of a similar discription of a similar poblem back in the early days of terratech on steam, BUT I do not remember what happened to 'fix' the issue
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,307
Likes
4,255
Points
675
Age
36
Location
UK
Website
www.youtube.com
#9
OK, I searched up the relevant threads (last one not so long ago) and merged @Lost Ninja's new thread, titled "[1.0.0.1]TT - Not Closing Correctly" with this one. Let me know if it's helpful (or different).

This steam issue has also been reported here in 0.7.9.1 and back in 2015, here, which was dug up at the start of this year (and I'm not sure if that was resolved...).
 

Django

PAYLOAD STUDIOS
Joined
Apr 21, 2016
Messages
238
Likes
432
Points
475
Location
London, UK
#10
There's a steam support page on this issue: https://support.steampowered.com/kb_article.php?ref=9764-ijvm-3291
I'd suggest following the steps reported, along with force quitting steam through Task Manager if none of the other steps help.

We've not currently aware of this being an issue tied specifically to our game, though if there's a reproducible circumstance we can look into whether this is an issue on our or Steam's side of things.
 

Lost Ninja

Well-Known Member
Joined
Jul 17, 2015
Messages
1,208
Likes
859
Points
520
Age
43
Location
Yorkshire Dales under a rock.
#11
There's a steam support page on this issue: https://support.steampowered.com/kb_article.php?ref=9764-ijvm-3291
I'd suggest following the steps reported, along with force quitting steam through Task Manager if none of the other steps help.

We've not currently aware of this being an issue tied specifically to our game, though if there's a reproducible circumstance we can look into whether this is an issue on our or Steam's side of things.
I'd already seen that when I searched about the topic when it first happened. Not especially useful as there isn't a TT process running, and you cannot check the game files while Steam thinks the game is still running. In my case it seems that @MedievalNinja6's post above solved it for me.
 
Likes: ZeroGravitas