[0.8.1] Game {save} cannot be found.

Joined
Jun 25, 2018
Messages
9
Likes
4
Points
9
Age
17
#1
Hi so I was playing terra tech campaign and when my friend asked me to join his multiplayer I was like sure and so i left my game saved it of course. And a little time went by from playing multiplayer after multiplayer i went to go into creativr and made a new jser because i didnt know if i created a creative game it would chabge my campaign so i did that, and little while after i got off terra tech for a bit and went to play other games. And when i got bored of the other games i went go play terra tech again and when I tried loading my world it gave an error stating "last Game save cannot be found. It has either been renamed, moved or deleted." Which I didn't do anything of that sort and when I went to go find my save file it showed up as i wanted it. What should I do?
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,052
Likes
3,844
Points
675
Age
36
Location
UK
Website
www.youtube.com
#2
Hi @Dominick J Araujo, sorry the game's giving problems.

Just to be clear, I have a few questions:

(1) Did you manually save your campaign game? (Rather than relying on the auto-save feature.)

(2) Did you reselect the original user name from main menu, after finishing with creative?

(3) Have you been able to reload any other save games OK previously? (If not, could you give it a quick try, please, making a new one.)

(4) I'm wondering if there's some issue with Windows permissions, potentially. Are you using an administrator account in Windows? In fact, what OS are you using?

(5) Are you on the default version of the game? (0.8.1. You've not selected the "Unstable" branch?) And it's up to date on Steam?

(6) Did you look in the file directory for save files, to see if it all looks correct? And there's a save file with a resonable file size, etc. "C:\Users\[Windows User Name]\Documents\My Games\TerraTech\Saves"

Thanks.
 
Joined
Jun 25, 2018
Messages
9
Likes
4
Points
9
Age
17
#3
(1) I did in fact save it manually.

(2)I did in fact select my user that I have the campaign on.

(3)idk because i only had one save with the campaign.

(4)I am in fact the administrator of my computer so yes and my computer is a windows 10 home 64 bit OS.

(5)and for this number I am quite confused on what u mean, do u mean i have to be on the one u suggested the (0.8.1). And howbwill I'm fine out on what version I am on? And if i am on the wrong one how, would I change it back as well?

(6)my save files are their they're named dom.sav and autosave.sav.

Thank you for your help
-Dom[/QUOTE]
 
Last edited:

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,052
Likes
3,844
Points
675
Age
36
Location
UK
Website
www.youtube.com
#4
(5)and for this number I am quite confused on what u mean, do u mean i have to be on the one u suggested the (0.8.1).
To be sure, it should not be a problem with any version. But it might be relevant to know, for the devs. It will be 0.8.1 if you've no idea how to change it. It tells you in-game on the blue launch screen and the pause menu in a world.

(6)my save files are their they're named dom.sav and autosave.sav.
Would you mind uploading them here? Drag-drop to a post, if they are below 1MB each - zip if not.

Also, your "Output_log.txt" file from "C:\Users\[Windows User]\AppData\LocalLow\Payload\TerraTech", please.

I'm going to move this thread over to the "bugs" section (from the "community help" section). Have added "[0.8.1]" and "{save}" to the title. Also, tagging a QA dev: @kae.


You could try verifying the integrity of the game files (through the game's properties in the Steam library) or just doing a full uninstall and re-install of the game, in case something's gone wrong with the install.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,052
Likes
3,844
Points
675
Age
36
Location
UK
Website
www.youtube.com
#7
So why did u guys need some of my game files again?
Fair question (and thanks for polite prompting here). I wanted to see for sure that they are valid files, of non-zero size. They look good. Contents look normal to me, opening in notepad (I don't know what I'd be looking for though). And they show in game fine...



But I can't get them to load in 0.8.1 or 0.8.1.3. Which is perplexing...



@kae, @Sammi, @Adriano - ideas, help?

My output log also attached here.
 

Attachments

Likes: Django
Joined
Jun 25, 2018
Messages
9
Likes
4
Points
9
Age
17
#8
That is what was happening to me... that's why I need your guys support. oh and my game updated to 0.8.2 so I don't know if that would be a problem as well.
 
Last edited:
Likes: ZeroGravitas
Joined
Jun 25, 2018
Messages
9
Likes
4
Points
9
Age
17
#10
do u know when the dev will respond, and has the problem I am having has it happened to anyone else before
 
Last edited:

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,052
Likes
3,844
Points
675
Age
36
Location
UK
Website
www.youtube.com
#11
do u know when the dev will respond
No idea. Maybe later today, maybe not for weeks... (The dev team seems to have been increasingly up against time constraints for the last year, with a very ambitious current aim to roll out a viable version 1.0 game to console *and* PC this summer.) Once someone does pick up on it, they may prioritise it (I think it seems a pretty bad bug).

has the problem I am having has it happened to anyone else before
I'm not sure if I've seen this exact problem before, but there's been a lot related to reading and locating save files, since the change of folder location.
 
Joined
Jun 25, 2018
Messages
9
Likes
4
Points
9
Age
17
#12
I mean i have time to wait its just that i want my campaigns to work before I head of to vacation because i am bring a laptop that won't run beefy games but terra tech will run smoothly on my laptop
 

Django

PAYLOAD STUDIOS
Joined
Apr 21, 2016
Messages
222
Likes
408
Points
475
Location
London, UK
#13
As far as I can tell the contents save file itself looks fine, but clearly loading it throws an exception and as a result we fall back to the save not found message.
I've not loaded it myself yet but looking in the log it's reporting:
ManSaveGame.LoadSaveData: Error loading save file "C:/Users/[User]/Documents/My Games/TerraTech/Saves/Guest\Campaign\Doms.sav" - Ionic.Zlib.ZlibException: Bad CRC32 in GZIP trailer. (actual(A53B7C3A)!=expected(998B3464))
This suggests it may have failed to read to the end of the file, but why that's happening on just these 2 save files is unclear. I'm adding a ticket and will have one of us take a look.
 

Django

PAYLOAD STUDIOS
Joined
Apr 21, 2016
Messages
222
Likes
408
Points
475
Location
London, UK
#15
We've identified the issue (unexpected value during serialisation) and will have a fix in for the next public build. We're still figuring out what caused the data to take on these values in the first place, but nevertheless it shouldn't fail to load the save the way it does.

I've attached a fixed version of your save game that should load up correctly :)
 

Attachments

Rhynoch

New Member
Joined
Jul 8, 2018
Messages
2
Likes
1
Points
2
Age
39
#17
Greetings all,
I am glad to know I am not the only one with this error. Ver 0.8.2, Win 8.1 64. Started a week or so ago with the auto save not loading and showing the save error. Then in the last couple of days the normal saves have all got the same problem. I was able to start a second campaign and save and reload just now but my previous campaign is broken as above. I have attached my most recent game save file. My current method is I load game and click the continue option and that worked fine. Then it went glitchy and so I was manually loading and at the end of each session I would manually save as a new file. Only recently have I started saving part way through a gaming session and overwriting the previous manual save. That may have been contributing to the trouble. Should you have time to fix my file also that would be great.
Thanks again and have a great week.
 

Attachments

Django

PAYLOAD STUDIOS
Joined
Apr 21, 2016
Messages
222
Likes
408
Points
475
Location
London, UK
#18
Hi Rhynoch. Looks like you encountered the same issue as Dominick, although it seems to have happened 8 times in your save file! (as opposed to 1 for Dminick).
If it's reproducible, would you mind sending us a save from before it happened, along with what you did afterward to help us figure out what causes this to happen?

I've attached a copy of your save file that loads up correctly.
 

Attachments

Likes: ZeroGravitas

Rhynoch

New Member
Joined
Jul 8, 2018
Messages
2
Likes
1
Points
2
Age
39
#19
Thanks Django,
I will test the file and see if I can cause it to repeat the error. I'll let you know how I go.
Thanks again.
 
Likes: Django