[0.7.9] Repeated crashes seemingly resolved by full re-install

ZeroGravitas

Breaker of Games
Jun 29, 2017
3,938
5,762
675
38
UK
www.youtube.com
So, I've been posting up ongoing crashes, while tabbed out, to this thread here. Wondering if the seemingly random instability is a game thing (probably), or a my computer thing (less likely, as not generally unstable, but I do have the RAM at a fairly high overclock).

But yesterday, I was getting repeated hard crashes in Creative Mode while in game, just (trying) to experiment with and fix my CompactAllCrafter (which has a critical flaw that non of its 343 workshop subscribers has mentioned :confused:).

So, I took @MrTwister's advice (from this comment) and did a full uninstall and re-install on Steam (did not entirely delete game folder). I've not had a crash since.
By the way, one of the ways to try fixing weird behaviors others never seem to have is by re-downloading whole game.

From what I have seen, consecutive updates/upgrades from earlier versions seem to occasionally accumulate errors in the game file structure/ which may come to a breaking point. For example I was updating my installation for a long number of versions and finally after 0.7.8.4 the game broke down and could not be started with simply a black screen after start, which did nothing at all and could be only killed via task manager.

So I deleted game folder manually and downloaded fresh and placed back copies of savegame and snapshot folders and all worked with no bugs. See if this works for you.
Certainly I've switched between game versions via the Betas tab many times.

Verifying game cache showed no problems.

I'd manually deleted the thumbnails cache a couple times previously (and again this time). I've even tried a snapshot stress test with 400MB worth of pngs, which caused the game to take a long time to load, first time, but no troubles thereafter.

Attached: 3 Zip files of the 3 crashes that created dump folders. 2 have screen shots of the context they occurred in. All involved crafting, usually with Fabricators active, but different exact contexts, and one entirely different game save (so have not attached save files, etc).
 

Attachments

Last edited:

ZeroGravitas

Breaker of Games
Jun 29, 2017
3,938
5,762
675
38
UK
www.youtube.com
In previous days I've had multiple other crashes while just playing with VTOL designs in Creative (no Crafting). See the unlabelled dump folder zips.

And one crash that was seemingly triggered by exploding an enemy so hard with cruise missiles that it threw an NaN error (and no dump), with the tech vanishing a moment before the crash (as with tech intersection crashes). Maybe worth adding to a different thread...?
 

Attachments