[0.7.9] Duplicate Turrets, Autominers & Glitched Save

Discussion in 'Bugs (Stable Only)' started by Thundercraft, Jan 12, 2018.

  1. Thundercraft

    Thundercraft Member

    Description:

    I've been playing with an older save and I've run into a bizarre bug. Notably, I went out to the desert to retrieve some Ignite Shards and Oleite Jelly from my autominers. When I got closer, in the distance I could see one of my turrets wobbling and spinning around as if it was having a seizure. Clearly, something was wrong with it. When I got close enough, I transferred control to my turret as I had a Cab on it. But I was shocked to see that there was a duplicate copy of my turret inside my turret, at the same spot. :eek: When I pressed {B} to try to lift up the turret I was in, the turret did not want to lift up because it was hung up on the duplicate. Eventually, it broke free of the duplicate but it badly damaged the duplicate in the process. Immediately, I got a warning message about my base being under attack, but that was only because my duplicate turret got damaged from removing the other turret. Then, when I tried to move my autominer complex (it was actually 4 autominers combined into a single unit), I discovered that it had a duplicate, too! o_O This time I was able to use {B} and move the one away from the duplicate without damaging it.

    However, after I did this, I loaded up my vehicle with raw resources to head back to my refinery/processing center and I started to leave... But then the lag got awful. Of course it crashed to desktop.

    Then I tried to continue my campaign from the last autosave, which was after I messed with the duplicate turrets but before I tried to leave and crashed to desktop. Well... this save is buggered and unplayable, but in an unusual way. This save does not lag out. Instead, my controls are mostly unresponsive. I say mostly, because I can pull blocks out of my inventory. However, it seems like I'm controlling a non-existent cab on the non-existent duplicate of my autominers (that I had recycled). At least, the viewpoint is locked at some point on or below the ground and I can't change my camera angle. Moreover, I can't transfer control to one of my other vehicles. I even pulled a new cab out of inventory and tried to transfer control to that, but the right-click menu will not appear. I can't even rename one of my vehicles, take a snapshot, anchor (or un-anchor), or use {B}.

    Computer Specs:
    - OS: Windows 8.1 64-bit (full, home)
    - CPU: Intel Core i5-4670K Haswell 3.4GHz
    - Motherboard: ASUS Z97-A LGA 1150 Intel Z97 SATA 6Gb/s ATX
    - Memory: G.SKILL Ares 8GB (2 x 4GB) DDR3 2133 CL10 Dual Channel 1.6v
    - Video Card: PowerColor Radeon R9 270X 2GB GDDR5

    Save:

    See below for this glitched save.

    Log file:

    I've attached the "output_log.txt" below. However, I did restart the game after it crashed. (Though, it is rather lengthy and I think this log file might have covered the incident.)
     

    Attached Files:

    Last edited: Jan 12, 2018
    JimmyBlether likes this.
  2. ZeroGravitas

    ZeroGravitas Moderator Moderator Canary Beta Deluxe

    Ah. So this would explain your previous bug report with the insta-crash save file...

    Tech duplication is a fairly commonly reported bug that's been an awkward for the devs to figure out and fix.

    The little new twist here is that techs on rotating anchors are no longer allowed to clip through other anchored techs (since 0.7.9 on the stable branch), so your duplicated turrets will have caused tech intersection related crashes [e.g. 1, e.g. 2], whenever they are loaded in (within 600m of you). Indeed, looking at my crash log, when opening your other save, there are NaN (non a number) errors at the end, before the crash, as is typical with that bug.

    I'm sorry, but these saves may be dead, unless the devs come up with a retro-active fix to erase duplicate techs (as they did with duplicated resource chunks, from a different bug).


    Your second bug sounds like this report, where the camera is stuck in mid-air, with no visible tech focused on, and half the UI locked out. As with this later report, you may well be able to double click to switch techs, if one is in vision, (as this doesn't require using the right click UI wheel, that is inaccessible). However, your save is probably still knackered.:(


    So these two bugs may be related then? (Not something I'd realised from previous reports.) For this reason I've not merged this new thread with either of the others. @Sammi / @Adriano may advise.;)
     
  3. Thundercraft

    Thundercraft Member

    That was my first assumption, too, that these issues may be related. Actually, I started to reply to the other bug report, suggesting they might be related, until I tried to continue my autosave and discovered how knackered it was. At that point I thought it was more appropriate to start a new, separate bug report.

    Well, this time it really wasn't much of an inconvenience. I've learned my lesson from last time and I keep frequent, multiple saves. The first time, though, was a bummer for me. However, your suggestion on exploiting the block duplication trick helped me recoup my losses.
     
    ZeroGravitas likes this.
  4. ZeroGravitas

    ZeroGravitas Moderator Moderator Canary Beta Deluxe

    Did you start over fresh with a brand new campaign? Or did you have a mid-way progress save archived? I wondering because a clear start is unlikely to have the same duplication glitch corruption, but an old save may have those wheels set in motion already (which was my assumption).
     
    Thundercraft likes this.
  5. Thundercraft

    Thundercraft Member

    I've been continuing play from an earlier save. I couldn't start over fresh when I hadn't even unlocked any Hawkeye stuff, not when I could still play an older save.

    Good to know. This may explain why my saves seem to becoming more and more unstable. Today, the game has been lagging out and crashing very frequently. Though, I can sometimes circumvent trouble by quitting to menu as soon as I notice severe lag and then continuing where I left off.

    Interestingly, I've noticed some more severe duplication. I today I saw an autominer complex - the same one that had the duplication in the above save - experience such severe duplication that there were at least 6 or 7 duplicates. It had mined out all the Ignite, so I recycled it... but it was still there. So I recycled again... and again.

    Also, interestingly, I've been doing Hawkeye missions and - of all things - Sergent Smash duplicated himself after completing a mission, leaving a clone of himself behind after what I assume was the original left. o_O
     
    Last edited: Jan 13, 2018
  6. ZeroGravitas

    ZeroGravitas Moderator Moderator Canary Beta Deluxe

    Yeah, he's just an anchored tech too. Like the other NPCs. So he was teleporting about when there was a bug with all new anchored techs, too.

    It sounds like you're going to have to start over a fresh game at some point, then, unfortunately. It's not like you can even just fly far away and start over. As far as I know it'll keep happening.:(
     
    Thundercraft likes this.

Share This Page