[0.7.9] Autominers mining inconsistantly or not at all.

Discussion in 'TT Stable & Console Bugs' started by Snipe, Apr 17, 2018.

  1. Snipe

    Snipe New Member

    Joined:
    Apr 17, 2018
    Messages:
    3
    Likes Received:
    3
    Game mode: Campaign

    Most, but not all miners won't mine more than 1 block per miner. They just stop after the first block.

    Exceptions to this are Carbonite which usually mines, but very slowly 1/45-120 sec.
    And Celestite which mines very quickly if it mines at all 1/4-7sec.

    This problem is about 6 days old but came on slowly only after discovering errors in the movement of blocks (refined blocks went into refinery) which dumped blocks all over and lagged the game so badly i had to search out the problem and discovered the spill along with resource blocks flying back and forth between miners. And the miners that had no blocks but were still mining. SO i checked all mining sites for dead miners and found out the issue was widespread. I usually toubleshoot my own problems so i wasn't thinking i'd need the save file and overwrote it many times since, sorry.



    I did some testing:

    Sold off all stacks of all inventory items, leaving only resource packs of 100 and small stacks of parts 20-30. (I had stacks of 800+)
    Deleted the Cache and very old Dumps.

    Deleted most of the very old savegame files.

    Deleted most of the Snapshots of techs.

    Redesigned my Homebase to a smaller, less blocks used version.

    Removed all miners, buildings and loose blocks from the area.

    Moved my whole operation 12000 clicks south.

    Set 6 groups of 4miners and watched each one for 5 minutes, still broken.

    Re-Installed from a 5400 to a 10k Raptor.

    I reset those 6 groups of miners and watched again.

    NO CHANGE, STILL NOT WORKING.

    I did load an old save prior to my sell-off and the miners worked fine.

    Video of very fast and malfuctioning miners




    My specs
    i7 2600k - AsusP8 - 16GB - eVGA_GTX960SSC - WIN7SSD - LGUW2560x1080
    Played in fullscreen mode on Fantastic, DOF off, highres trax off. No graphical/performance issues.

    Any help would be great since i was very into the mass mining idea, so my game is pretty much dead without it.

    Snipe

     

    Attached Files:

    ZeroGravitas likes this.
  2. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,641
    Likes Received:
    2,759
    Thanks for the report. :) This sounds very weird... :confused:

    At 0:42 in your video, though, I see a chunk jump clear across your collection tech, to a reciever that shouldn't be able to reach it, and that looks to me like this bug reported by @QuackDuck: https://forum.terratechgame.com/ind...shly-mined-resources-when-set-to-turbo.15219/

    So, I'm wondering if maybe there's a non-obvious cause here, like the Auto-miners actually outputting the resource chunks, but them instantly teleporting somewhere else, picked up by an incorrect receiver (due to memory /data management issues in the game, or whatever's going on...).

    Otherwise I have no clue, except it sounds like there the bug is attached to the save, somehow, as you say.

     
  3. Icarus_The_King_Of_Angels

    Icarus_The_King_Of_Angels S H I N Y Mad Scientist

    Joined:
    Nov 6, 2015
    Messages:
    562
    Likes Received:
    909
    Speaking of autominers, I simply CANNOT get four to mine on a resource seam. At least one doesn't anchor. Every. Single. Time.

     
  4. Snipe

    Snipe New Member

    Joined:
    Apr 17, 2018
    Messages:
    3
    Likes Received:
    3
    "Auto-miners actually outputting the resource chunks, but them instantly teleporting somewhere else"

    Yes i should have posted that i looked into that also. I thought the same thing so i changed my homebase and all miners to sellers only and flew out so i could see both my base and the 2 miners in the video and again sat for 5-10 minutes and neither base nor miners registered any credits except 4 chunks did pop but only after being reloaded into view.

    Another example in the savegame file... 2 miners east of the homebase in the flats are on veins right next to each other. Carbonite and Celestite. Carb is usually very slow and Cele fast but on these 2 miners they both run very fast. About a chunk every 6 sec for both. They never slowed after 10 minutes so i took video. They are also in view of my homebase.

    Fast miners 2




    *Icarus, grab a miner put a cab on it, go into buildmode, line up the side and back attach nodes and piece 4 together first, snapshot it. Then Bmode fly it to where you want it B again to place it. All 4 will always work unless they are on uneven ground/obstructed.

     
    #4 Snipe, Apr 17, 2018
    Last edited: Apr 17, 2018
    ZeroGravitas likes this.
  5. Icarus_The_King_Of_Angels

    Icarus_The_King_Of_Angels S H I N Y Mad Scientist

    Joined:
    Nov 6, 2015
    Messages:
    562
    Likes Received:
    909
    That's precisely what I do; maybe I'm just unlucky with the ground being **just** uneven enough to be a problem haha

     
  6. ZeroGravitas

    ZeroGravitas Breaker of Games

    Joined:
    Jun 29, 2017
    Messages:
    2,641
    Likes Received:
    2,759
    Did you check out the tutorial in my video? How to place them here. It's not where it looks like it should be, visually, and you may need to rotate the mining tech a little sometime to jog them all into effect. But I've only seen total failure to anchor all miners (in this configuration) on obviously impossible terrain.

     
  7. Icarus_The_King_Of_Angels

    Icarus_The_King_Of_Angels S H I N Y Mad Scientist

    Joined:
    Nov 6, 2015
    Messages:
    562
    Likes Received:
    909
    It's only ever one or two at a time that fail to anchor. And turns out I'm just impatient. I've since gotten it to work. XD

     
    ZeroGravitas likes this.
  8. kae

    kae PAYLOAD STUDIOS

    Joined:
    Mar 7, 2018
    Messages:
    272
    Likes Received:
    325
    Hiya Snipe, I've tested this over on our side and this issue does repro on your save file, but not on any of ours.
    Also strangely I've found that the Rodite ore does spawn, just not when you are close to it (Tested at the same location as in your video).

    Does this issue only occur for you on this save file or do you have others that are also effected?

     
    ZeroGravitas likes this.
  9. Snipe

    Snipe New Member

    Joined:
    Apr 17, 2018
    Messages:
    3
    Likes Received:
    3
    Hey kae, yes strange things happening.

    Well i always make 2 or 3 saves and save often just in case. So i should, but sadly i deleted most of the saves i had trying to solve the problem along with cache, snapshots, dumps ect, sorry. But i do have a save that was just before the problem. I think it's within 10 minutes or so of the save in question. I'll have to look at it cuz i'm not really sure how long the problem had been going on initially. So it might have the problem also.

    I did start a new game with a new name and new seed to see if it happens again. So far i just get the occasional very fast miner, but all veins have worked as they should.

     
    ZeroGravitas likes this.
  10. Zorgomol

    Zorgomol Not a Number

    Joined:
    Apr 9, 2018
    Messages:
    97
    Likes Received:
    137
    My long-running campaign save just hit 150 hours and any miners I put down don't work properly any more; they exhibit the same kind of bug.

    So for a repro case I'd suggest artificially setting the game time to around 160 hours if possible and see what happens with autominers. I'd guess that player techs that are outside normal tech activation distance are updated with lower frequency, meaning larger time delta.

    Pro tip: never use floating points for time calculations. Google "catastrophic cancellation" and "roundoff error" for more info.

     

    Attached Files:

    ZeroGravitas likes this.
  11. Khaine

    Khaine Well-Known Member

    Joined:
    May 29, 2018
    Messages:
    203
    Likes Received:
    181
    Same problem, can't get any auto miners to mine. Sent everything I built into my inventory except my truck, moved about 2k away from the area and tried setting down another auto miner. Still no joy. It mines 1 raw resource, then sits there for half an hour doing nothing. Then spits out another one. Or doesn't.

    Like snipe, this problem only started happening to me once I began exploring further out, using more than one vehicle and adding cabs and AI to vehicles, mining stations, sentry guns, etc. Earlier in the game I had 5 auto miners next to one another, each mining their own vein of erudite, and had absolutely no issues whatsoever.

    I'm also having the indestructible AI cab problem, not sure if these are different symptoms of the same coding problem or not.

     
    ZeroGravitas likes this.
  12. mozuo

    mozuo Well-Known Member

    Joined:
    Jun 4, 2018
    Messages:
    6
    Likes Received:
    13
    Me too. Once it occurs, it continues. I do not know why such things happen. Also, when this phenomenon occurs, the enemy's control block becomes solid. And at this time, the way of progress of "play time" is not normal. In my environment, that phenomenon occurred after the playing time exceeded 146 : 38. I attach my save data. Please verify. But, my case is in ver.0.8.1.



     

    Attached Files:

    Django, HAL and ZeroGravitas like this.
  13. DrShadox

    DrShadox GeoCorp worker

    Joined:
    May 23, 2018
    Messages:
    245
    Likes Received:
    222
    Got this porblem too but atfter waiting several minute near them everything was fix by itself.

     
    ZeroGravitas likes this.
  14. Django

    Django PAYLOAD STUDIOS

    Joined:
    Apr 21, 2016
    Messages:
    212
    Likes Received:
    357
    Good ol floating point precision.

    We were adding Time.deltaTime (0.016f) to the current game time (say 150hrs = 540.000s). Now floating points only have so much precision (23 bits to be precise) and if we want to fully express the above sum total (540.000,016) we need 29 bits! That means we're losing 6 bits, or most of what's behind the comma!

    As @mozuo noticed, total time played becomes inaccurate past this point, and systems using that time would similarly be affected.

    You'll be pleased to know that your autominers will still have been "mining" the resources, it's only the dispensing that was affected. Once this is live in a new build you should start seeing your accumulated resources popping out at the catchup interval (10s) instead of the mining interval (30s).

     
    mozuo, harpo99999, DrShadox and 2 others like this.
  15. mozuo

    mozuo Well-Known Member

    Joined:
    Jun 4, 2018
    Messages:
    6
    Likes Received:
    13
    Thank you. I confirmed that this problem has been improved in Ver.0.8.1.2.

     
    kae, Django and ZeroGravitas like this.
  16. DrShadox

    DrShadox GeoCorp worker

    Joined:
    May 23, 2018
    Messages:
    245
    Likes Received:
    222
    You mean it's fix or it's worst than before ?

     
  17. mozuo

    mozuo Well-Known Member

    Joined:
    Jun 4, 2018
    Messages:
    6
    Likes Received:
    13
    I mean it has been fixed. I am sorry that my English is not good. I will scold the translation of Google.

     
    DrShadox and ZeroGravitas like this.
  18. DrShadox

    DrShadox GeoCorp worker

    Joined:
    May 23, 2018
    Messages:
    245
    Likes Received:
    222
    No problem ^^ i wasn't sure.

     

Share This Page