[0.7.8.2] R&D MEGABUG {dispensers and anchored techs vanish}

JimmyBlether

Regrettably Inactive (long term)
Jul 31, 2017
2,660
3,012
570
Somewhere off the map
tinyurl.com
OK, I was just building a new SFS tech and after blowing up the turrets I pressed the return to checkpoint button and this happened: (pic not working, all my anchored techs and the dispensers had vanished, but the blocks still were there and the dispenser effect still was there, but my techs radar pins were far north of my position)

I then drove in the direction of the pins and then pressed return to checkpoint to drop off my tech and get a faster one. I returned to see no floating blocks but they were lying around 50m north in line over the bumps so I flew over to where the radar pins were and I saw this:
screen402.png
Save and output log below.
(output log not working)
 

Attachments

Last edited:
  • Like
Reactions: Legionite

Gameslinx

Well-Known Member
Oct 19, 2015
1,081
1,120
525
18
A cab, stranded in deep space
I think you just drove off too far and they unloaded? Been a while since I've played, but it sounds like what used to happen with the R&D structures. Restarting the chamber should fix it.
 

JimmyBlether

Regrettably Inactive (long term)
Jul 31, 2017
2,660
3,012
570
Somewhere off the map
tinyurl.com
I think you just drove off too far and they unloaded? Been a while since I've played, but it sounds like what used to happen with the R&D structures. Restarting the chamber should fix it.
Saved and reloaded, it seems to be permanent.

Edit: Now a random tech marker is on the radar even though there is nothing there...
(screenshot not working...)

Edit 2: I'm guessing they didn't unload, because they reloaded 1km north of spawn.

Random tech marker save:
 

Attachments

Last edited:

BenBacon

Founder Of Bacon, Inc
Jan 15, 2017
1,555
2,235
525
Gulag
Stuff like this has been happening to me too
Once I flew up to a turret to test out some flares and the turret just vanished and there was a crosshair on the minimap
Also I don't see anything weird in the pic except for the TT sign vanishing ( unless you are super neat )
 

JimmyBlether

Regrettably Inactive (long term)
Jul 31, 2017
2,660
3,012
570
Somewhere off the map
tinyurl.com
Stuff like this has been happening to me too
Once I flew up to a turret to test out some flares and the turret just vanished and there was a crosshair on the minimap
Also I don't see anything weird in the pic except for the TT sign vanishing ( unless you are super neat )
look at the distance, and the fact there is no bumps. Check the saves, you will see...
 
  • Like
Reactions: BenBacon

JimmyBlether

Regrettably Inactive (long term)
Jul 31, 2017
2,660
3,012
570
Somewhere off the map
tinyurl.com
I just got the same issue. All the dispensers disappeared. (Note: they're still technically there because I can't drive through them, but you can't see them. They also re-appeared after resetting the R&D test chamber.)

View attachment 19070
That is normal for the bug. Also, RAMPS! HOW???

Edit: AWESOME UPDATE!
 
Last edited:
  • Like
Reactions: {insert_name_here}

BenBacon

Founder Of Bacon, Inc
Jan 15, 2017
1,555
2,235
525
Gulag
I think I figured out how to replicate this issue ( already slightyly mentioned )
1. Get very far and very high from the spawn point
2. Click return to checkpoint
What happened to me was the dispensers dissapered and the blocks on them flew towards the TT sign
I think the syptoms of this bug are random
 
  • Like
Reactions: JimmyBlether

Boomik

...
Apr 2, 2017
3,527
2,651
670
Stalk me not
Maybe this is also because of the anchor physics bug? Because the dispensers and turrets are technically still anchored when they disappeared.
 

nikitaign

Well-Known Member
Mar 13, 2017
54
66
420
16
Russia. Somewhere
Hi, I was having fun finding out info about new blocks and I set bombs on my plane to try them out.
1. Fly away away away.
2. Hit Go To Checkpoint button.
3.You will see that EXP blocks are gone.
4. Boom.screen32.png