[0.7.7.x] - Battery low message on fully charged batteries

layer1

Well-Known Member
Joined
Jun 14, 2017
Messages
246
Likes
306
Points
470
Age
59
#1
Steps to reproduce:

1) Add uncharged battery/batteries to tech (i.e., drop a tech from snapshot)

2) Charge the batteries rapidly.

Battery low messages start as soon as you assume control of the tech and cycle from battery to battery until the warning has shown for all of them. If the batteries are charged rapidly, the warning continues to display for each battery although they may be fully charged.

Really, the battery warning should only show once for the tech since all batteries drain and charge equally.

Really really, there should just be a single indicator of some type on the HUD showing overall battery charge. Optional hover display for techs not currently controlled by the player would also be nice. I'm getting into suggestions now so I'll leave it at that. It's probably a known thing since I saw the same behavior when I last played (0.7.5, I think).

The tech in the pic has roughly a dozen each of GSO and GeoCorp batteries and was charged at a 'battery tree' using 24 Venture remote chargers. This can be reproduced using any tech.

edit: I just signed up for R&D and see fuel and power gauges, so that's nice. :)
 

Attachments

Last edited:

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,929
Likes
5,638
Points
675
Age
36
Location
UK
Website
www.youtube.com
#2
Thanks for the report.:) I think what's happening here is that the game has to go around every single battery on the tech, pointing out that it's low for 3 seconds each, so it takes a long time to finish on big techs, but does stop eventually (and is definitely a bug)... As you said, actually, excuse me.:confused::


Personally, I really wish there was an option that disabled this type of pesky tip overlay, always tickling my eyeballs and ruining screen shots/recordings.o_O

R&D save file of my setup attached below.

I see this in 0.7.7.0 stable and it's still present in 0.7.7.5.

Edit: several edits...
 

Attachments

Last edited:

Lord Zarnox

Founder of the IFTTES
Joined
May 31, 2017
Messages
1,865
Likes
2,403
Points
520
Age
20
Location
Australia
#3
Really, the battery warning should only show once for the tech since all batteries drain and charge equally.
Well now, that is a flaw in the system isn't it... The warning only shows when you are controlling the tech, and all batteries effectively add capacity to a single pool of charge, yet the warning treats the batteries as if they worked independently.
Really really, there should just be a single indicator of some type on the HUD showing overall battery charge.
edit: I just signed up for R&D and see fuel and power gauges, so that's nice. :)
My guess is that the reason the power gauge doesn't work yet is for a similar reason to the multiple battery warnings (assuming they even made code for it in the first place). Actually, here is a suggestion: seeing as the battery charge is displayed on a model, why not just make the power gauge render the 5 segments in screen space rather than world space, and have them in a fixed position relative to the camera. Sure, it isn't the ideal solution, but it should work.