[0.7.7.2] Bug - Scrappers continue functioning when de-anchored.

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,178
Likes
4,046
Points
675
Age
36
Location
UK
Website
www.youtube.com
#1
  1. Create a tech with a cab, scrapper (any corp) and storage space attached to it's output (e.g. a silo).
  2. Feed the scrapper a couple of blocks.
  3. Click to de-anchor the tech.
  4. Scrapper continues to hold the blocks and munch through them, outputting chunks and/or components.
This looks particularly wrong with the GeoCorp scrapper, since it's output port becomes shielded, so the chunks get pushed out through the bottom of the scrapper block and may fall on the floor instead.

I think I'd noticed in earlier patches (e.g. 0.7.7.1) that scrapper continue to hold onto their (giant) stack of input blocks, after de-anchoring. Which means they can get pushed around the floor by the block input attraction force.

Related feedback: scrappers should be able to pick up and hold fewer blocks. GSO can take 10, which isn't so bad, provided they're not the bigger types. But GeoCorp can take 15(?) and they're inevitably bigger, so it makes a right bundled, writhing mess, constantly dropping and picking blocks up as it tries to create a nice stack about it's input maw (as if all blocks should behave like tidy little resource chunks).

(I may add video later, although probably unnecessary.)
 

Sammi

PAYLOAD STUDIOS
Joined
Oct 9, 2017
Messages
94
Likes
86
Points
425
Age
27
#2
@ZeroGravitas I'm currently looking into it and I can't seem to get it to occur. Would you mind providing me with a screenshot or video of this occurring? Thanks! :)
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,178
Likes
4,046
Points
675
Age
36
Location
UK
Website
www.youtube.com
#3
Would you mind providing me with a screenshot or video of this occurring?
Okies. I had some old footage from R&D, but thought I'd double check in 0.7.7.3, Creative mode, so here's a fresh, simplified demo:
Note that the scrapper must already have grabbed some blocks before de-anchoring, for this to occur (maybe this was why no replication?).

This video also shows a little silo stored resource positional glitch-out at 40 seconds.

And I throw in a little cab-less tech undo trick, for fun, @1:16.

Finally, demonstrating that (I think) scrappers try to stack too many resources at once (around 2:00); half the block types are too big for that, so scrappers continuous grab, fail, drop and fling them about instead. Could do with scaling it back from 10-15 (it currently varies depending on corporation) to 3-5, I think. As a simplest fix of the messy mechanism.


Edit: oh, and check scrap magnets too, I think they continue to hold parts for at least a while after de-anchoring.
 
Last edited:

Adriano

PAYLOAD STUDIOS
Joined
May 16, 2016
Messages
2,536
Likes
1,244
Points
570
Age
36
#4
Cheers @ZeroGravitas , I've been able to repeat this now. I think the Block Magnets are fine, since they don't need to be anchored to function, just attached to a cab in some way. I've mentioned it in the bug report just in case.
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,178
Likes
4,046
Points
675
Age
36
Location
UK
Website
www.youtube.com
#5
I think the Block Magnets are fine, since they don't need to be anchored to function, just attached to a cab in some way.
Ah. That's a very good point.:oops: Maybe I confused myself there... (Not hard.)

Not seeing any trouble with them now. Only irritation is that the attractive buzzing sound continues while tech is in build beam, rather than de-activating, as when detatched. (And the force itself fights against the push from the build beam area clearing 'breeze'...?)