[0.7.6.3] Is there a way to see {map} Chunk load lines? {Base vanishing.}

jyoumon

Well-Known Member
Joined
Nov 25, 2015
Messages
3
Likes
0
Points
403
Age
29
#1
I'm having an issue since 0.7.6.3 that when i drive away from my base to do harvesting the darned thing just disappeared (like aliens keep stealing the thing!) but all the resources are left behind (cheeky aliens, leaving messes around).

So I'm wondering..is there anyway to see the chunk load lines for areas like Minecraft does? I'm pretty sure the two games have pretty near the same mechanics there. I mean..if im building my base on a strange load area i cant see..that's just gonna make this game more anger building than creative building.

Doesn't help i've lost something like $150,000B worth of base blocks each time now 3 times in a row -___- (its like i just don't learn my lesson ^__-)
 
Joined
Jun 24, 2017
Messages
1,772
Likes
4,050
Points
525
Age
16
Location
Near a duck pond in Britain
Website
duckduckgo.com
#2
We can't see load lines unfortunately. About your base, the way I would fix it would be to back up your save and try to move it slightly in one direction to avoid the load lines. Usually only resources fall off instead of the whole base vanishing when your base straggles a load line, so is this actually a bug?
 

Django

PAYLOAD STUDIOS
Joined
Apr 21, 2016
Messages
232
Likes
423
Points
475
Location
London, UK
#3
Hi @jyoumon, while displaying the map segments won't be something we're likely to do, having your actual base disappear is not something we've come across before.
Would it be possible it was destroyed by enemies rather than something going wrong?

Having a save game to inspect might help, though it might be difficult to figure out what went on if your base is already gone.
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,161
Likes
4,011
Points
675
Age
36
Location
UK
Website
www.youtube.com
#4
Would it be possible it was destroyed by enemies rather than something going wrong?
Seems unlikely, given @jyoumon would have had to be within 180m for the enemies to be able to move/fire, and then further away than that for the debris to de-spawn, all without noticing.

There were still some treadmill world issues in 0.7.6.3, with enemy techs teleporting/displacing away? (And here.) So maybe the base has gone 'hiding' somewhere nearby, in a related bug....?

Note: I've added some additional info to the thread title, to aid finding things.:)
 

jyoumon

Well-Known Member
Joined
Nov 25, 2015
Messages
3
Likes
0
Points
403
Age
29
#8
Ahh, thanks for all the replies and the changes :p

Ohh and if it makes any difference the base had 2 defenders (Geocorp rotating anchor, Geocorp battery, Hawkeye Defense AI, and a dozen weapons and 2 shields) and those actually stayed behind in the exact same spots..but the bases just...Poof...gone :/ so maybe not a chunk line error....most setups for a solid maneufacturing base is 8 mixed silos, GSO fabricator, Geocorp Fabricator, Venture fabricator, and Hawkeye Fabricator on the same conveyor line, this way they can all accept resources from the pads lines, a second line would feed refined resources onto the storage line. This also contained a fully expanded component factory, one of each of the corps scrappers, multiple Geocorp batteries, multiple havok shields, and multiple Hawkeye repair bubbles for protection. So i doubt attack would have done it.

Ohh and i think i can still give the save, but i rebuilt a new base (very similar design) in a new area, the other is still showing on the map though so you can visit its last location at least.
 

jyoumon

Well-Known Member
Joined
Nov 25, 2015
Messages
3
Likes
0
Points
403
Age
29
#9
Hi @jyoumon, while displaying the map segments won't be something we're likely to do, having your actual base disappear is not something we've come across before.
Would it be possible it was destroyed by enemies rather than something going wrong?

Having a save game to inspect might help, though it might be difficult to figure out what went on if your base is already gone.
you can try if you want, but i doubt it would help :/
 

Attachments

P

Pink Kitty

Guest
#10
Hi @jyoumon, while displaying the map segments won't be something we're likely to do, having your actual base disappear is not something we've come across before.
Would it be possible it was destroyed by enemies rather than something going wrong?

Having a save game to inspect might help, though it might be difficult to figure out what went on if your base is already gone.
Disappearing bases is an ooooold problem :p
 

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,161
Likes
4,011
Points
675
Age
36
Location
UK
Website
www.youtube.com
#11
Disappearing bases is an ooooold problem :p
Any hints or links? Think it might sound the same as previous ones? A bug resurrection...

And @jyoumon, it'd be great to have any screenshots, or snapshots of any of the bases that went missing.:) For context. Even if you don't consider there's anything special to see. (Perhaps next time, if it's too late now.)
 
P

Pink Kitty

Guest
#12
Any hints or links? Think it might sound the same as previous ones? A bug resurrection...

And @jyoumon, it'd be great to have any screenshots, or snapshots of any of the bases that went missing.:) For context. Even if you don't consider there's anything special to see. (Perhaps next time, if it's too late now.)
Well, specific details weren't released (AFAIK) when the bug was fixed, but it was revealed to be something to do with the chunks unloading when you left the area.

When it reloaded, the techs had fallen through the ground.
Generally you could tell, because they'd show on the radar, but not be there.
 
Likes: ZeroGravitas

ZeroGravitas

Breaker of Games
Joined
Jun 29, 2017
Messages
3,161
Likes
4,011
Points
675
Age
36
Location
UK
Website
www.youtube.com
#13
@jyoumon (and others): You may be interested to know that the world tiles are a grid of 384 meter wide squares, with the first one centred on the {0,0} origin point, so it's edges are at {0,192}, etc.
After double checking with people who know what they're talking about, a tile is 384 units in length and width
And (0,0) is at the centre of the starting tile, so (192,0) would be the edge of the starting tile.
From that you should be able to work out exactly where all the seams are, to avoid when debugging a vanishing or malfunctioning base (if these problems aren't resolved anyway).:)
 
Likes: Adriano

Zorgomol

Not a Number
Joined
Apr 9, 2018
Messages
129
Likes
228
Points
145
#15
ARISE, THREAD, I SUMMON THEE WITH THIS SWEET OFFERING OF A CURIOUS REPRO CASE...

I don't know if this bug was supposed to be fixed, but it clearly happens.

System: i5-4750, NV GTX1070, Windows 7, 32G RAM
TT Version: 0.7.9.2 (TT_unstable)
Occurrence: 100% (on my machine, 3 out of 3 tries)
REPRO: Load the attached save from a FRESH START of a 0.7.9.2.
Observed: AIs fire guns, base does not exist.
ANTI-REPRO: Load the attached save again.
Observed: Guns do not fire, base is there processing.
REPRO#2: Exit to Windows, start the game, load the save.
Observed: AIs fire guns, base does not exist.

Rinse and repeat.
Additional comments: vanishing base spans the world line at 3648m.
 

Attachments

Likes: ZeroGravitas