0.7.3.3 Crafting with lots of silos causes stutter

Zargn

Administrator
Nov 30, 2015
967
1,084
500
Sweden
Found this while testing my new UltiCrafter, seems like the flashing on crafting blocks causes small freezes.

To reproduce:
1. Make a large base with lots of crafting blocks. (Or use the only in this thread)
2. Try to Craft a block.
3. Every time the blocks flash there should be a small freeze.

As allways, if you need more info then please ask. ;)
 

Attachments

  • Like
Reactions: tomo_cjt

Adriano

PAYLOAD STUDIOS
May 16, 2016
2,592
1,349
570
38
Do you only get this when setting your base to craft @Zargn ? Last time I checked R&D I was getting a stutter like this consistently no matter what I 'm doing in the mode.
 

Zargn

Administrator
Nov 30, 2015
967
1,084
500
Sweden
For me there is a constant stutter in the spawn area in R&D, but nowhere else.
And yeah, I get this stutter when I set the base to craft something.
And the stutter from using the base is much worse than the stutter close to spawn.

I can make another video if needed.
 

Dorn

Well-Known Member
Jul 2, 2017
16
6
205
I also have this problem with a base I made. I had a lot of large silos and every time I chose to craft something the whole game would freeze a second. Almost like the communication system has some extremely unoptimized coded.
 
P

Pink Kitty

Guest
I have replaced all my silos with one small silo, with a GC scrapper attached, and one resource block partially eaten.

no lag.
 
  • Like
Reactions: Zargn

Dorn

Well-Known Member
Jul 2, 2017
16
6
205
To narrow down the bug for the devs more. I noticed it got significantly better as I drained resources out of my silos. Perhaps empty silos don't cause the manufacturing lag.

This is in campaign by the way. I had no significant base structures or AI's. I got zero lag just moving around or even fighting massive tech battles near the base. It ONLY lagged the moment I told a factory to produce something.
 

Adriano

PAYLOAD STUDIOS
May 16, 2016
2,592
1,349
570
38
We've had a few reports of this since, it looks like it tends to happen if you have a large base and are trying to craft a higher tier block. The added complication causes the game to pause briefly whilst it figures out what to do next. Do you guys think you're seeing something different?
 
P

Pink Kitty

Guest
We've had a few reports of this since, it looks like it tends to happen if you have a large base and are trying to craft a higher tier block. The added complication causes the game to pause briefly whilst it figures out what to do next. Do you guys think you're seeing something different?
This fits with what i see. The bigger the base, the worse it is. The more fabbers running, the worse it is.
Also, if you have multiple fabbers running, they steal resources from each other, and it screws up the crafting.
 
  • Like
Reactions: bedbathandbrett

Dorn

Well-Known Member
Jul 2, 2017
16
6
205
We've had a few reports of this since, it looks like it tends to happen if you have a large base and are trying to craft a higher tier block. The added complication causes the game to pause briefly whilst it figures out what to do next. Do you guys think you're seeing something different?
That's not exactly it. My base was small ( I basically demolished everything but the factory). My factory was medium size (4 component factories) a couple refineries and factories). I had a LOT of 3x3 silos FULL of stuff though. As I emptied it out it started working faster. It seems heavily related to the amount of silos in use or simply the amount of resources.
 

Adriano

PAYLOAD STUDIOS
May 16, 2016
2,592
1,349
570
38
@Dorn What kind of blocks are you trying to craft? Higher level ones? That require high level components?
 

Dorn

Well-Known Member
Jul 2, 2017
16
6
205
@Dorn What kind of blocks are you trying to craft? Higher level ones? That require high level components?
Nope. I reloaded a save with the problem and it could happen with a simple GSO one block. It does seem better in 7.5.3 though. It doesn't lag every time I pick something now. The first time I pick something it lags for sure but after that it's somewhat random.
 

Adriano

PAYLOAD STUDIOS
May 16, 2016
2,592
1,349
570
38
@Dorn Any chance you can upload the save with this base in it so we can take a closer look please? Cheers :)
 

Adriano

PAYLOAD STUDIOS
May 16, 2016
2,592
1,349
570
38
Thanks @Dorn, I took a look at your base. I also had the game freeze breifly when I selected a block to craft, but if I then set it to craft the same block, it would not freeze. If I select a a different block, it freezes again. Is that what you're seeing?
 

Dorn

Well-Known Member
Jul 2, 2017
16
6
205
Thanks @Dorn, I took a look at your base. I also had the game freeze breifly when I selected a block to craft, but if I then set it to craft the same block, it would not freeze. If I select a a different block, it freezes again. Is that what you're seeing?
Yep. At some times it was extremely bad. After emptying the silos though it got much better. It surprises me honestly. A simple search of the silo data structures shouldn't cause that even if it's wildly inefficient. It was so bad I wondered if a bunch of data was getting wildly copied around.
 
P

Pink Kitty

Guest
Thanks @Dorn, I took a look at your base. I also had the game freeze breifly when I selected a block to craft, but if I then set it to craft the same block, it would not freeze. If I select a a different block, it freezes again. Is that what you're seeing?
Also does it when you add or remove blocks, while crafting.
Makes it hard to get anything done in the background, while you're waiting for stuff to get built.
 
  • Like
Reactions: ZeroGravitas

Mr-Vagabond

Well-Known Member
Dec 21, 2015
188
117
445
23
I don't see any kind of issues about that. My big crafting base is working all right and I have a lot of silo ( perhaps not enough ? i think i have under 100 silo but more than 50 )
 
P

Pink Kitty

Guest
I don't see any kind of issues about that. My big crafting base is working all right and I have a lot of silo ( perhaps not enough ? i think i have under 100 silo but more than 50 )
Can you paste a snap please?
So we can give it a go, and maybe learn how to avoid this in our bases?