[0.7.2] Plugging in wireless mouse soft-locked the computer.

Discussion in 'Bugs (Stable Only)' started by streak1, Jan 26, 2017.

  1. streak1

    streak1 Well-Known Member Canary Beta Deluxe Wiki Mod Streak1 Old Banners

    Not sure if it was the mouse that caused the issue or something else, or if it was even the game's fault, but here's what happened:

    I was in R&D, messing around with the new (to me) crafting system. The mouse I was using before has a messed up scroll wheel, so I went to plug in my wireless mouse I use for my laptop. It's a Logitech M560, and I've never used it with the computer before, if that means anything.

    I plugged the mouse in, moved it around to check if it was working, and it was. The stream window thing was open, so I closed it. I picked up a static delivery cannon to put it in the SCU, and suddenly everything stopped working.

    The game was still running, since I could see the resources spinning around. My wireless mouse wouldn't work, no buttons, no movement, no scroll wheel. The mouse I had plugged in didn't work either, nor did my keyboard. I couldn't even toggle off num lock. I tried plugging the mouse adapter in and out, still nothing. Tried ctrl-alt-delete, alt-F4, nothing happened. Since I had no way to close the game without a keyboard or mouse, I had to reboot the system via the power button. Even that didn't shut it down, so had to force it off by holding the button down.

    Really weird issue. Again, not really sure if it is the game's fault, but I haven't had any issues with the wireless mouse or any of the other peripherals since the forced reboot, so I'm not sure.
     
  2. Adriano

    Adriano PAYLOAD STUDIOS Developer QA Lead Canary King

    Hi @streak1 , thanks for posting this. I assume you only had this problem whilst plugging the mouse in when TerraTech was running? Did you try without the game running? And does it do it every time you plug the mouse in with the game running? Cheers buddy :)
     
  3. streak1

    streak1 Well-Known Member Canary Beta Deluxe Wiki Mod Streak1 Old Banners

    I tried plugging it in and out without the game running, and I had no problems. Haven't tried plugging it in after the computer started yet. I did the same with the game running, didn't happen again.

    Maybe it didn't like installing the drivers or something? IDK.
     
  4. Adriano

    Adriano PAYLOAD STUDIOS Developer QA Lead Canary King

    Could be. If the drivers installed whilst the game was running, might have caused the problem. Don't suppose you saved the output log at all?
     
  5. streak1

    streak1 Well-Known Member Canary Beta Deluxe Wiki Mod Streak1 Old Banners

    Nope. I figured I wouldn't be able to, but in hindsight I might have after restarting. But I have since played the game.
     
  6. Adriano

    Adriano PAYLOAD STUDIOS Developer QA Lead Canary King

    No worries mate, I've logged the issue anyway. For future reference, the output log gets preserved after you exit the game, and only starts to be overwritten when you start a new game :)
     
  7. streak1

    streak1 Well-Known Member Canary Beta Deluxe Wiki Mod Streak1 Old Banners

    Just had a similar problem in the latest stable, after closing and opening my save so I could copy it for a separate bug.

    My mouse didn't stop working, but my keyboard did, and this time I didn't do anything that would have triggered it. My wireless mouse was already plugged in before I opened TT. I did plug in some wireless headphones for the first time on this computer today, but they were already unplugged before I opened the game, so I don't think that would be the cause.

    Since I had mouse control, I could get out of the game without shutting off the computer. Output log and saves included. Save 1 was before the issue, save 2 was after the issue, after closing the game.
     

    Attached Files:

Share This Page